Qubes Clipboard not working with Windows HVM

I’m having trouble with the clipboard on a newly built Windows HVM on a new Qubes R4.1 install.

Qubes Windows Tools version:
Install was default, except option to disable UAC left disabled.
Qubes OS version: 4.1.1
Windows Version: Windows 10 Enterprise 10.0.19042

This all worked OK with 4.0.3 and the appropriate version of QWT.

Installation method:
- This VM started as a Hyper-V (Generation 1) VM that was imaged with our SCCM infrastructure.
- I installed QWT and the Xen drivers.
- Used qemu-img to convert it to raw
- Transferred to dom0 and created the VM.

The VM booted up fine and everything that I normally use looks great, except for the clipboard sharing. If I copy from another qube and try to do a CTRL-Shift-V in the Windows qube, nothing happens. If I try to copy data out of the Windows qube (CTRL-Shift-C), I get the text you normally see when pasting data into the qube (“Global clipboard contents copied to qube and wiped”). In reality, there’s no flow of clipboard in or out of the HVM.

Neither the QdbDaemon nor the QrexecAgent services are running. Attempting to start them gives error, "Cannot start service QrexecAgent on computer ‘.’.

Manually running qrexec-agent.exe does nothing. It closes immediately, but run

Other issues:
I tried enabling the logs per https://github.com/Qubes-Community/Contents/blob/master/docs/os/windows/windows-tools41.md#configuration but no logs are generated even with verbose logging enabled on everything. I’m assuming because the service won’t even start.

There don’t appear to be any indicators of the issue in the Windows event log. Nothing related to those services.

Did I miss something obvious here? I’ve been daily driving qubes for a while, but this is giving me a headache. Thanks for any help.

I can confirm that in my case copy to Windows HVM is working, but copying from it doesn’t work with the strange message Global clipboard contents copied to qube and wiped, instead of “…fetched…” message.
Both qrexec and qubesd are up and running with QWT

1 Like

Does @jevank have any idea?

Could you try to install QWT to VM under Qubes OS? I’m not sure that all Xen components applied ok under Hyper-V.

Are there any related log messages?..

Thanks for the response. No log file is generated in C:\Program Files\Invisible Things Lab\Qubes Tools\log folder? I haven’t used Windows VM for several months, only until several days ago. Before that, it worked with QWT flawlessly as far as I can recall.
So I guess it’s something with updates for dom0, probably, while as I can see it, stubdom-linux hasn’t changed recently… (1.2.4-1.fc32)?

It’s not something I can’t live without, most probably patience until some further updates will resolve it…

I did try reinstalling after I got it up and running in Qubes.

Same here. I opened networking between a VM at the same tier of my security model and am RDPing to it right now as a workaround.