Qubes Canon network printer configuration

Hi, I’m new user of Qubes. I want to configure my home network printer for Qubes but not even know how to start. I can’t find any useful guide. I have Pixma TS5150. For that model only “working” drivers that I know are proprietary drivers from Canon. But this drivers comes with automagic installation script that not working on Qubes - can’t find printer since is up to two qubes away (I create standalone for printing). How should I configure sys-net and sys-firewall to passtrough the printer to printervm? I know that this drivers are using CUPS but it hink they are addng something to it, and I don’t know what I should set in CUPS admin panel.

Also is it any better way to login in to CUPS admin panel then adding password to passwordless root?

Link to drivers:

if you want to learn qubes and wanted printer worked, you may want to read this first.

especially enabling-networking-between-two-qubes

the rest is you need to find how to set up network printing in linux.

Hi - welcome to Qubes.

You haven’t said in what way the script is not working, nor why your
standalone cannot see the printer. Or perhaps this is the same problem.
It should not be necessary to change sys-net or sys-firewall to access
the printer.
Don’t make any changes to your system until you are clear on what the
problem is.

I’d start by checking that printervm can “see” the printer at all - you
can use ping or connect to a web interface - see the manual for
Check this and report back.

I never presume to speak for the Qubes team.

When I comment in the Forum or in the mailing lists I speak for myself.

I can ping and connect to web interface. Maybe I will try to grab CUPS config from standard linux computer on which script was able to install printer.

I tried copy the printer.conf and ppd file from linux in which scripts configure everything, also managed to configure everything manualy using hints from that topic:

in both cases all jobs hangs infinitely. I have problems with configuring that printer on other machines (not printing but returning status) - windows and linux, but here it’s obvious that there is no communication with printer.

just do step by step.
attach the usb to printervm, install driver into this vm, print test, would that work ?

Yes, I done that yesterday. Scanner also works on USB. I also found newer driver on canon crappy managed support page . If I want drivers for my printer I was only option to download some old drivers from 2017, but using google You can find versions from end of last year on singaporean canon site. Of course from the site itself You can only search using printer models… But yeah I now have current version of drivers, that still not work… I also try adding printer using IP address instead of cnijbe2 address. In that case got the information that “printer is busy” instead of hang in processing when I try to print.

I was finally able to make my printer/scanner work in printserver qube. Printer require installing drivers and finding it over IP in system-config-printers, for some reason it works on JetDirect protocol but not on IPP and Canon cnijfilter2. Making scanner works require abandon the idea of using scangearmp2 and installing gscan2pdf and sane-airscan. Also I have to make airscan-discover my raspbbery pi to obtain the ports using by scanner, since in qubes I wasn’t able to make avahi-discover or airscan-discover to work. Now I got next question. I tried to use @unman’s (GitHub - unman/qubes-print) idea to implement printing in other qubes but it fails. I added qubes.Printer rule in my dom0:

@anyvm PrintVM allow
PrintVM @anyvm allow

and not getting any error popups so I think it working. Also changed print to PrinterVM in rc.local for qube from which I wan’t to print. Of course rc.local is chmod +x. So I think everything should be setup. I starting system-config-printer in my PrinterVM connect to the localhost/ then run print in qube and not got any printer except of print to pdf. When I start system-config-printer in that qube i got “error: ‘success’” same as when I don’t set rules properly.

When I changed policy to ask, I’m asked even few times If I allow this access when I go to print menu, enter loclahost:9100 address in browser, or open system-config-printer. But nothing happens later…

Got it, have to re run bind-mount script to add my files.