Qubes broken: how to (re-)install Desktop Environment

My QubesOS is totally broken so I would like to try to reinstall my Desktop Environment. I really don’t care which Desktop Environment can make it work, but following the docs for KDE on Qubes I just executed the single line from the docs in my Dom0 terminal but after installing it did absolutely nothing:

$ sudo qubes-dom0-update kde-settings-qubes

Yes, I did restart several times afterwards. Here the output after running the command again:

[me@dom0 ~]$ sudo qubes-dom0-update kde-settings-qubes
Using sys-firewall as UpdateVM to download updates for Dom0; this may take some time...
Qubes OS Repository for Dom0                    2.9 MB/s | 3.0 kB     00:00    
Package kde-settings-qubes-5.12.3-5.fc32.noarch is already installed.
Dependencies resolved.
Nothing to do.

Any help on how to get Qubes back to an operational state would be amazing!

  1. Have you try to reboot?
  2. The the “broken” part is quite probably in /home/user directory (path depends on your username), maybe you should try to reset it to fix everything.

Yes, tried multiple reboots

How do I “reset it”?

If it were me, I’d probably just do a full backup, reinstall Qubes, then restore from my backup. It may technically not be necessary, but it’s a simpler and more foolproof solution that doesn’t depend on special knowledge or executing a complex technical procedure correctly. You also don’t have to worry that your tinkering inadvertently broke something else that you’ll discover only later.

1 Like

I am running Ubuntu and Windows on the same machine and I’m massively afraid of Qubes again nuking my EFI partitions so I’m more likely just going to quit my experiment of switching to QubesOS.

If I were you I would try to rename /home/user to /home/user_old and create new empty /home/user setting the same chmod and chown.

If you are not familiar with things that I said then this recommendation probably should be ignored, because it can be too complicated.

Thanks! I just created an empty home directory for my username, set chown and chmod and logged out and in again. Now all the Qubes were fine from the menu (makes sense) but I managed to start a browser via qvm-run but still couldn’t move the window, couldn’t open Window Manager from the System Tools etc.

So I’m still curious how to actually get KDE to run out any other approach!

Well, something is really broken. Maybe installing other DE is not a good solution.
Maybe re-installation is better.

@unman can you help this person with a KDE installation tip?

1 Like

I ended up re-installing Qubes - total clusterfck…