Qubes Boot Loader Help #7542

I am experiencing what I believe to be issue #7542. I have been learning Qubes for approximately 2 months and I think it’s great. However I can’t commit because each time I get comfortable I loose all my work. If I unplug change remove anything the ssd then I can no longer boot. This is driving me crazy. So I just reinstalled, again. Please tell me 1) how to back up to my hdd so I can stop losing all my dayum information. 2) How to confirm that my data is r/rw (maybe) protected. From reading I see UEFI tends to act this way. Please help me make sure this is my last install of qubes. I can’t take the pain of starting over, again………

Did you try to fix it as stated in that issue?

boot my install media, run Anaconda rescue and:

Mount the bootloader partition
Copy the contents of /mnt/EFI/qubes/ to /mnt/EFI/BOOT/
Rename grubx64.efi to bootx64.efi
Rename grub.cfg to bootx64.cfg

I tried but finally gave up. That is why I installed fresh and have it updated and working. I just want to ensure I don’t loose everything if I move ports or anything happens.

I guess I’m asking in Dom0 is there a way to make sure the boot files are there and working prior to shutting down?

Hi Tim - and welcome to the forum!

My interpretation of your situation is:

  • You have successfully installed Qubes on SSD, connected via USB
  • After installation, you can boot and run Qubes without issues
  • If you unplug/move the USB connection to a different port and boot the computer, then you cannot boot Qubes again

– is that a correct description of your issue?

If so, then you should be able to follow the instruction from @apparatus, by opening an terminal in dom0 and copy the files around:

sudo -i
cd /boot/efi/EFI
cp -r qubes/* BOOT
mv grubx64.efi bootx64.efi
mv grub.cfg bootx64.cfg

If you are currently unable to boot Qubes, then you could try the following:

  • Connect the SSD drive via USB to the computer
  • Connect the USB installation stick to the computer
  • Select the Installation stick as the boot medium
  • When you see the “Install Qubes OS R…”/“Test media and …”/“Troubleshooting - …” menu, hit c to got grub> prompt
  • Type configfile ( and hit the Tab key on your keyboard
  • You should get a list of “Possible devices are” - eg. hd0 hd1 hd2
  • Test each possible device, by typing configfile (hd0, and hit Tab - it should give you a list of partitions on each drive - eg hd0,gpt1 hd0,gpt2 hd1,gpt1 hd1,gpt2 hd1,gpt3
  • You need to find the partition that has the file /EFI/qubes/grub.cfg - so in my example, I should try each of:
configfile (hd0,gpt1)/EFI/qubes/grub.cfg
configfile (hd0,gpt2)/EFI/qubes/grub.cfg
configfile (hd1,gpt1)/EFI/qubes/grub.cfg
configfile (hd1,gpt2)/EFI/qubes/grub.cfg
configfile (hd1,gpt3)/EFI/qubes/grub.cfg

– with a little luck, you’ll find the GRUB menu for you qubes installation and be able to boot into Qubes OS. Once you have Qubes OS running, you can open a terminal in dom0 and do the steps above.


Yes, this is the way! If anyone has a fresh install it is way easier to copy them from Dom0.

hi, i have the same issue except for some reason my /mnt/efi/BOOT does not exist in my boot loader partition anymore??? I don’t know much about coding but i’ve spent many hours trying to figure this out with this being where i’ve become stuck.

not just that, a lot of the file locations where i am told to go come back as not existing. this partition has to be the boot loader partition it has /mnt/efi/qubes but nothing else i really don’t know what to do.

Is there a way to wipe and reinstall the boot loader partition altogether?

I can elaborate more tomorrow as it’s really late and my brain is completely fried.

Hi Dogg – welcome to the forum! :slight_smile:

I think it is “a similar, but slightly different” problem … :wink:

When you have had time to rest/relax, could you explain in more details where you are stuck, what you have tried and the output from the commands?

Some quick guesses/questions for the post:

  • Is your computer set to UEFI boot or Legacy boot?
  • If you are able to boot your computer, then what do you get with: ls /sys/firmware?
  • Were you able to use the GRUB from the install stick to find the GRUB-config on the harddrive?
  • What did you get, when you typed: configfile (hd and then pressed the Tab-key?