Qubes boot fails after second restart

Hey, thanks for any help in advance!!

I’m installing qubes os 4.2.0 on my HP probook 450 G10 on an external drive. On my main drive I have manjaro installed. The install works perfectly fine; The first phase works fine, then I reboot it and unplug the installation medium and the setup of all the template VMs works fine, and I get into a properly working qubes setup. If I then restart the system, however, then from that point onwards booting from the external drive quits immediatly and it starts booting from my main drive. I am sure the qubes os drive has higher boot priority. Even if I specifically instruct the bios to boot from my qubes drive, the computer immediatly returns to the bios.

I have tried to fix it by editing /etc/default/grub by adding efi=attr=uc to GRUB_CMDLINE_XEN_DEFAULT in dom0

I’m wondering how I can make qubeOS boot when booting of the qubeOS drive.

PS: UEFI troubleshooting | Qubes OS
seems to be outdated as xen.cfg no longer exists since 4.2.0

1 Like

You need to use UEFI fallback path:


thank you so much! This worked for me. Is the cause of this the hardware that I’m using? Do you recommend mentioning that you have to do this on the entry I’m gonna make in the hardware compatibility list?

No, it’s not hardware-specific, it’s just how UEFI works. On boot the UEFI checks the entries and if the entry points to non-existing device (be it USB or some internal drive that was removed from the system) then it removes this entry.


hi, i have the same issue except for some reason my /mnt/efi/BOOT does not exist in my boot loader partition anymore??? I don’t know much about coding but i’ve spent many hours trying to figure this out with this being where i’ve become stuck.

not just that, a lot of the file locations where i am told to go come back as not existing. this partition has to be the boot loader partition it has /mnt/efi/qubes but nothing else i really don’t know what to do.

Is there a way to wipe and reinstall the boot loader partition altogether?

I can elaborate more tomorrow it’s just really late i’ve been up all night trying to figure this out and my brain is completely fried

Hey, sorry for the late reply!! I hope you have either fixed it already or have not spent too much time on it. What apparatus said fixed it for me, though I don’t quite remember the exact steps (I agree, the thread he linked is a bit confusing)