Qubes 4.2-rc4 --install-windows-tools not working


Installed qubes 4.2-rc4

Installed windows 10 pro

Installed qubes-windows-tools in dom0

sudo qubes-dom0-update qubes-windows-tools

Trying to install qubes-windows-tools in the windows vm:

qvm-start Win10Pro --install-windows-tools

Windows VM starts fine, qubes reports dom0:loop3 - /usr/lib/qubes/qubes-windows-tools-placeholder.iso (Win10Pro) is available to vm, but don’t see any drives other than C: anywhere, opened file browser, opened cmd prompt, no other drives available.

My first time installing windows 10 on qubes, so I might’ve missed something. I followed the guides.

Grateful for any suggestions!


QWT is not available since QSB-091, it was replaced by a text file instead.

If you still want to proceed and you are aware of the risks, you can downgrade to version 4.1.69 with this command:

sudo qubes-dom0-update --action=downgrade qubes-windows-tools
1 Like

Thanks, no, I wasn’t aware of the security risks, I’ll read up on that.

Downgraded, same problem. Rebooted, still no drive added, although qubes says it’s there.

Not sure if this would matter, but I haven’t yet activated the windows, don’t want to waste a key on a temporary test install.

Try to disable hibernation inside the Windows qube:

In an admin command line:

powercfg -h off

Shutdown the qube and then execute the start command with --install-windows-tools

thanks, no, that’s not it, i’ve run that several times

I checked the dom0 journalctl logs, don’t see anything

Maybe I’ll start over, build a new windoze vm from scratch, reboot often :slight_smile: probably missed something along the way

Well, that’s weird. I just tried it again (with Windows 10 LTSC) to make sure it still worked, and I was able to install the tools and copy files from Linux-based qubes to the Windows qube.

Make sure that QWT is at version 4.1.69 (dom0: rpm -qa | grep qubes-windows-tools) and that you really have disabled hibernation (powercfg -a should say that it’s off). Shutdown the Windows qube completely and then do qvm-start <qube-name> --install-windows-tools
The ISO should be available in the explorer.

If that doesn’t work, you can mount the ISO on a Linux qube, upload the .msi installer from the ISO somewhere online and download it to the Windows qube to install it.

1 Like

omg i’m a dork sometimes

I didn’t run cmd as administrator doh!

rebooting now


hah user account locked, won’t let me in lol it’s always something

it did let me install though, gave me the drive d: so should be good to go


1 Like


I cloned the original windows vm, went thru it all again, and user account is locked again.

I did enable auto-logging in, before installing the qubes-windows-tools, maybe it doesn’t like that.

One more time…

1 Like

3rd time was the charm, had to create a 2nd admin account, because for some reason the first account always got locked, so annoying

The sound is choppy, I’ll have to tweak it, but it’s working.

Thanks again