Qubes 4.2 issue (likely bug). Setting dom0-update-proxy through the Global Config GUI

Going into the Global Config GUI, selecting the Updates panel on the left, then attempting to set the dom0 update proxy. It appears to reset the selection to what was there before when you press Apply. In fact, it IS changing the setting, but you have to exit the GUI and restart it to verify that it worked.

Yes, I can confirm that I encounter the exact same behavior (selection goes back to previous item, though relaunching the tool shows dom0 update proxy has been updated).
Qubes 4.2.0 with kernel 6.6.2-1.fc37