Qubes 4.2 installation fails at networking

Trying (and failing) to install Qubes 4.2.

I’ve used Qubes for a while, and tried to upgrade, but the upgrading gave me issues, and eventually left me with the network not working. Figured I’d install from scratch.

I verified the iso I downloaded, and verified the USB both before installing, and during the installation.

Installation went fine.

Rebooting and just accepted the standard options to configure.

During configuration, at the networking part, the USB mouse stops working, and I get this error dialog. USB keyboard no longer working either, so can’t select OK. Only way out is to switch off. Switch on again, and can’t enter disk password.

I looked here Installation troubleshooting | Qubes OS but don’t know how to install network drivers before the configuration is done, and don’t know how to disable the network card in the BIOS.

The issue is not about network but about sys-usb failing to start.
Most probably you need to enable no-strict-reset for the PCI USB controller/s attached to sys-usb:

You can disable the sys-usb autostart using this kernel option:

But you should be able to enter the LUKS password (not user password) even if your sys-usb will fail to start later. NOt sure why it’s not working for you.

1 Like

I had the same issue using templates fedora-38-xfce,
with fedora-39- xfce & gnome everything worked without any issue.

I managed to find the solution.

Basically, the issue is with the usb qube, so to fix, all I did was untick the box that said, "Use a qube to hold all USB controllers (create a new qube called sys-usb by default)

Then the installation succeeds.

After a little trial and error, I managed to create a USB qube that works on my desktop.
Using lsusb in dom0, I made sure that both my USB keyboard and USB mouse are plugged into the same controller (Bus 005 in my case).

Then create the USB qube with:
qubesctl state.sls qvm.usb-keyboard
(completed with no errors)

Find the BDF as described here:
(in this case my BDF was 07:00.4)
Use Qube Manager to edit sys-usb settings (without launching sys-usb)
In Devices tab, remove 07:00.4
(For me, this was the missing ingredient causing me to lose keyboard and mouse when starting sys-usb, this post clued me in to the solution: Broken system after installing USB qube - #37 by DVM)
In dom0, edit /etc/default/grub like so:
GRUB_CMDLINE_LINUX=“$GRUB_CMDLINE_LINUX usbcore.authorized_default=0 rd.qubes.dom0_usb=07:00.4”
grub2-mkconfig -o /boot/grub2/grub.cfg

Reboot, unt voila!