Qubes 4.2, debian-11-minimal broken after update

Hello everyone,

I am testing the latest weekly build of Qubes 4.2 and for me it works well enough to go further. I have installed the debian-11-minimal template that is available and after an update and restart of the template, I am unable to open the terminal on the template. With qvm-run I get this output:

[qubesuser@dom0 ~]$ qmv-run -u root debian-11-minimal xterm
Running ‘xterm’ on debian-11-minimal
debian-11-minimal: command failed with code: 84
[1]+ Done qvm-template-gui

Are you able to tell me what is going on?



Maybe try enabling security (maybe updates candidates also) in /etc/apt/sources.list.d/qubes-r4.list prior to updating?

Something like this:

# Main qubes updates repository
deb [arch=amd64] https://deb.qubes-os.org/r4.1/vm bullseye main
#deb-src https://deb.qubes-os.org/r4.1/vm bullseye main

# Qubes updates candidates repository
deb [arch=amd64] https://deb.qubes-os.org/r4.1/vm bullseye-testing main
#deb-src https://deb.qubes-os.org/r4.1/vm bullseye-testing main

# Qubes security updates testing repository
deb [arch=amd64] https://deb.qubes-os.org/r4.1/vm bullseye-securitytesting main
#deb-src https://deb.qubes-os.org/r4.1/vm bullseye-securitytesting main

Thanks for the suggestion but I already tried that. Not working unfortunately.

Using kernel-latest?

using debian 11 in 4.2 break the system since earlier days, i forgot which package lead to this.

fedora 37 or self build 38+selinux worked perfectly.

Could also just try to move beyond bullseye to bookworm.

I will try bookworm thanks for the suggestion

1 Like