Qubes 4.1: VPN (corporate) host name resoution problems

To connect to my office I use Pulse Secure. In my 4.0 installation, I had a vpn vm which had Pulse Secure installed, and provided network to all my work-related vm’s. This worked without any problems.

When I configure the same thing in 4.1, the VPN connection is established and everything works from the VPN VM itself. All VM’s that use this VM as a network provider is able to reach IP addresses on the internal network. However, DNS resolution does not work at all. I cannot resolve neither external nor internal hostnames from these vm’s.

If I manually edit /etc/resolv.conf and copy the content of the same file in the vpn vm, then everything works correctly.

I have tried to set up a vpn vm using both fedora-34 and debian-11, and I see the same issue.

How is name resolution via a vpn vm supposed to work, and does things work differently in 4.1?

I figured it out. I was missing the network-manager service in the VPN VM.

1 Like

Hi, I am experiencing a similar problem with my sys-vpn based on qubes-tunnel: for some reason openvpn cannot resolve DNS. I fixed this problem by editing my qtunnel.conf file and adding the remote server IP address. That said, I would like to understand why sys-vpn is not resolving DNS. Can I ask you, which packages did you install on the VPN VM in order to make it work again?



I am now testing Qubes 4.2 RC4. I have a QubeVM with Pulse Secure that connects to the company VPN and allows me to access network resources. But I’m trying to get other QubeVMs to use this as a “net qube”, and it’s not working. I can only ping the QubeVM with Pulse Secure. But I can’t browse the internet or access company resources. I have tried adding the network-manager service to the QubeVM with Pulse Secure, but it does not provide access to the other QubeVMs either.

Is there something else I need to configure or activate?