Qubes 4.1: qubes-dom0-update error

I’ve been testing the 4.1 pre-release version for quite some time and I have encountered a few bugs over the time that are usually mentioned at GitHub qubes-issues.

One thing I encountered more than once at some point is the following error when trying to update dom0:

Problem: garcon-0.6.4-4.fc32.i686 has inferior architecture

  • package xfce4-settings-qubes-4.0.4-1.fc32.x86_64 requires garcon >= 0.6.2, but none of the providers can be installed
  • cannot install the best update candidate for package garcon-1000:0.6.4-4.fc32.x86_64
  • package xfce4-settings-qubes-4.0.4-1.fc32.x86_64 conflicts with garcon = 1000:0.6.4 provided by garcon-1000:0.6.4-4.fc32.x86_64
  • problem with installed package xfce4-settings-qubes-4.0.3-2.fc32.x86_64
  • cannot install the best update candidate for package xfce4-settings-qubes-4.0.3-2.fc32.x86_64
    (try to add ‘–skip-broken’ to skip uninstallable packages)

I tried the suggested command but it doesn’t help. During my first try of 4.1 a few months ago this error occurred after a while but only when enabling the testing-repo but this time it did occur without enabling testing repos.

Has anybody testing 4.1 encountered the same problem?

I haven’t found this yet. But it might be something worth posting on qubes-issues as a Bug Report to make the developers aware.

I’m getting exactly the same problem on Qubes 4.1 too.

I will open a bug report on qubes-issues soon.
Thanks for your answer. Good to know! I will link to the issue on GitHub when I’ve submitted a report in order to follow any answer or development.

Edit: I just tried a few things and you can update dom0 for now with excluding the following package:

sudo qubes-dom0-update --exclude="xfce4-settings-qubes-4.0.3-2.fc32.x86_64"

Edit1: I’ve submitted a bug report

1 Like

I forgot checking the qubes-devel-Google Groups, where the problem has been known for quite some time. My apologies!

Whoops. My bad. Sorry @Raphael_Balthazar was the one suggesting opening up a bug report. Here’s something I didn’t know.

No problem. After all the post at qubes-devel has a solution, which is the important thing.

The (ugly, but working) solution is to remove (only!) garcon package
first and then install the update:

sudo rpm -e --nodeps garcon
sudo qubes-dom0-update


1 Like

Be very careful, this solution could mean trouble.

I did exactly like recommended but after rebooting my applications menu is now gone which means that I can only start apps via CLI.

I will have to search for another solution.
I don‘t know if this had something to do with an update or removing this garcon package. Anyhow, if this happens to you, thanks to GitHub user @jpouellet I could reinstall the applications menu with this command

sudo qubes-dom0-update --action=reinstall $(rpm -qal | grep /usr/share/applications | xargs rpm -qf | sort -u)