Qubes 4.1 - Network-Manager VPN connection setup

I tried to redo https://micahflee.com/2019/11/using-mullvad-in-qubes/ for my new QOS 4.1 installation. Unfortunately, I cannot select any VPN Connection Type:

network-manager-vpn-setup

OpenVPN is installed (debian-11 template), did I miss something? Or has there been any changes in QOS 4.1 (it worked in QOS4.0, fedora template)

Restart the qube and then try right click on the networkmanager applet in panel.

Done, same issue. Nothing to select.

Are you on a minimal template or have you changed any other defaults?

No, all standard. I just wanted to set all on debian-11 in my QOS 4.1. It is a fresh installation.

Could you please verify:
Create AppVM, provide network, based on debian-11, firewall
Settings add network-manager
Try to select a VPN Type

I think he uses fedora templates. Might be that you have to install OpenVPN in standard debian templates first but I would not know as I avoid debian.

As I wrote before, openvpn is already installed.
… ok, let’s wait for someone who can verify this (with debian-11)

have you installed the network-manager-openvpn package?

No, but if I remember correctly I also didn’t do this on QOS 4.0 Fedora. Anyways, could you please point me to the docs or is it a simple one-liner in dom0 or in the debian-11 template?

Anyone here who could quickly (1 min) do this:

Thanks

Same.
You need the additional packages as unman pointed out.

1 Like

Ok, I managed it.

As a solution that everyone can follow easily:

Mullvad VPN setup on Qubes OS 4.1, based on Debian:

Additional step / preparation before you start with Micahflee’s vpn guide:
Launch a Terminal in your Debian Template (Template: debian-11) and run:

user@debian-11:~$ sudo apt install network-manager-openvpn-gnome -y

reboot your Qubes.

crosslink: PSA: using a VPN under Qubes for Dummies - #5 by Sven