Qubes 4.1 all usb devices unusable

Good morning,

Since Monday I have been trying to get QubesOS 4.1 up and running on my PC (B550 mobo, latest BIOS with proper IOMMU groups, 5900X CPU). However, when I try to install 4.1 I get the following errors in the logs:

Note the following errors:

xhci_hcd 0000:02:00.0: Error while assigning device slot ID
xhci_hcd 0000:02:00.0: Max number of devices this xHCI host supports is 127.
xhci_hcd 0000:0a:00.3: Error while assigning device slot ID
xhci_hcd 0000:0a:00.3: Max number of devices this xHCI host supports is 64.

Those 2 device IDs are the 2 USB controllers in my system both pretending they are at maximum capacity (which shouldn’t be the case with just a usb mouse/keyboard and usb stick with the installer plugged in).

Because of this a bit later in the logs (right after we reach [ OK ] Reached target Basic System.) we see the following error which effectively kill the installation:

stystemd-gpt-auto-generator[1158]: EFI loader partition unknown exiting.

This is, I assume, happening because the usb stick with the installer on it has been disconnected due to the earlier problem.

What I have tried so far:

  • Install Qubes 4.0.4, this works just fine.
  • Install Qubes 4.1 with IOMMU disabled in the BIOS, this also works. Reenabling IOMMU in the BIOS will again kill all the usb devices.
  • Try to install Qubes 4.1 with the latest kernel from here. This also does not work, same issue.
  • Run the latest version of Tails on the PC (with IOMMU enabled) this works just fine. This seems relevant to me because the kernel versions are very close (Qubes 5.10.90 vs Tails 5.10.92).

I was hoping someone might know more about how to solve this issue, or have a better idea than me about how to proceed. Otherwise things I might still try are:

  • Trying to run 4.0.4 with newer kernels to see if that results in the same problem.
  • Trying the upgrade path from 4.0.4 to 4.1 if a new kernel for 4.0.4 works fine.
  • Creating an installation ISO for 4.1 with the kernel from 4.0.4.

Thanks in advance for the help :slight_smile:

1 Like

Looking at the github issues I expect that the following 2 issues are caused by the same bug:

Similar to issue 1, I also get that error in the logs and get to exactly the same point during the installation process. If he would run the installer in troubleshooting mode he would probably get the same output as is visible in my attached image.
Issue 2 suggests that 4.0.4 works just fine (as it does for me) but upgrading to 4.1 breaks the system. The issue suggests it is a freeze, but I expect the usb devices are just not working, most likely again the same underlying issue.

Were you ever able to resolve this? I’ve spent hours trying to figure this out; I’m glad I found your post. I’m about to try out the weekly build.