Qubes 4.1 5950x x370 prime pro issues

I was a happy qubes user for 4 years, until i made the mistake of wanting to upgrade my CPU from a 1700x to a 5950x on x370 prime pro motherboard.

First of all let me list system specs:
Mobo x370 prime pro with the latest bios that supports this cpu
32gb ram
AMD rx460 2gb

So I backed up all the qubes from my previous installation, and downloaded the 4.1 iso. Then the issues start to appear, if i dont disable IOMMU (i remember i had a similar workaround to install qubes with the 1700x) i get black screens after the “relinquish vga” and it doesn’t get past that. If i do disable IOMMU i can get past the first part of the instalation, then I can re-enable IOMMU and go through the second part, but when it finally boots up sys-firewall etc wont boot up because they claim my system is not IOMMU compatible.

I have tried weekly builds, both the latest kernel ones and the non-latest kernel ones to no avail. I’ve verified the isos, used different methods to burn the usb all that to no impact.

In the troubleshooting guide it suggests to edit BOOTX64.cfg
but there’s no such file in that location (EFI/BOOT/BOOTX64.cfg)
There’s grub.cfg, with none of those options to comment out, and there’s BOOTx64.EFI.

I have tried changing every bios flag that could be relevant, I read reports of people not being able to install with C-States active, so I disabled that, I’ve tried with CSM on and off, IOMMU on and off, legacy and uefi, sometimes I do get to a final install but nothing works because sys-firewall says my cpu doesn’t support IOMMU (even though IOMMU is enabled at the bios level at that point, but yes it had to be disabled for the first part (pre-reboot) of the install).

I’ve ran out of ideas, and I’m regretting even upgrading to begin with. I rely on this machine for work and I’m desperate, to the point I might just stick another distro in it and just use KVM for separate VMs.

Any help would be great.

Update: So I’ve decided to try something else, I decided to go for 4.0.4 where I can actually comment out those options on BOOTX64.cfg and it worked flawlessly, system boots, everything seems to work. But then I did a mistake of thinking that upgrading to 4.1 was the way to go, long story short the first thing to do was to install the new whonix templates, because if one doesn’t do that the whole in-place upgrade will fail because whonix 15 is EOL’d. So i did that and went through the full process just to make it broken again, after the LUKS password it just hangs on “Starting Hold until boot process finishes up”. I have run out of ideas and gave up at this point, I’ll stick with 4.0.4, but that doesn’t seem like a great long term plan.

1 Like

Another update: So rocking 4.0.4, all templates updated, backup recovered, all running smoothly. The issue though is that Whonix support has been deprecated and I use it quite often. Any ideas on what could I be missing to get 4.1 to work?