Qube starts, but nothing launches from it

One of my qubes suddenly won’t start any applications. Terminal windows, web browsers, nothing. The qube itself launches without issue (qvm-ls shows it as “running”) but I’m unable to launch any apps in it.

I tried cloning it, but the clone has the same behavior (not too surprised there).

It worked fine when I shutdown yesterday, and all my other qubes seem to be fine.

Any idea where to start troubleshooting this?

1 Like

Update: I’m able to access the console using “xl console”, but only via CLI. Nothing will launch. So it seems to be some kind of Xorg issue. Maybe the vm’s X server is having an issue?

So if you start a graphical application via the terminal it does not start? If it does, then it might be a problem with the applications shortcuts (in which case you can just Refresh Applications from the qube settings).

I can’t even start a terminal. Clicking anything from the application menu does nothing, even Terminal and xterm.

running “qvm-run personal xterm” from a dom0 terminal never launches xterm in my personal qube. But the same command for any other qube works fine.

I’m able to poke around inside the affected qube using “xl console personal”, though. So it’s running. but Xorg in the qube doesn’t seem to be.

Did you install any applications, enable any services, or change any settings?
When you are at the console, you can check to see what’s running - you can
also check to see if the usual Qubes helpers are installed (qubes-gui-agent etc)

Check to see if the usual qubes-rpc is good - qvm-copy working?
Assign more memory and restart.
Check the logs from the console, and look for any oddities.

Welp. I feel like an idiot.

I should’ve checked that first, but my only recent change was to add a line calling the keychain ssh agent utility from my .bashrc. The same line works without issue on several other systems I manage. I didn’t think that could’ve been the issue But commenting the line out fixed it.