Qualcomm Atheros Killer E220x -no wired network Qubes-kernel 5.10+

Hey, now I need to try more to get my wired connection working with those newer kernels 5.10+, becauseo they are long time supported and I need it for some features.

With the Qubes latest stable Kernel 5.88 or sth like that my network is comletely working, but at newer kernels I always have only my wireless lan avialable. It looks everything fine afer booting ,but then there is the message the network has been disconnected and I can not connect to it. If I click at my wirless home spot and enter the key it is working. But I like to have it with wired connection. So, my network card is not fully supported by these new kernels and I need a driver or what is the problem here and what can I try to solve it. Because it is annoying to enter everytime the wireless key after booting and to have those usual wlan problems :wink:

Disable the wireless card in the BIOS or remove it and try to reboot. Re-Enable and/or reinstall. Old windows tricks…

Hey,
unfortunately it doesn’t work. I disabled my wirless card, but the same problem.
First everything looks good and after a few seconds it says the network has been disconnected. It is marked as active and I can click disconnect, but that doesn’t affect anyting to the problem. At lower kernel 5.4.98 there is no problem. But now the problem is been existing for about month and every update of the kernel I hope that it is working again , but nothing changes hehe :wink: But of course thank you very much for ur try to help :slight_smile:

I now noticed that at Kernel 5.10 + I have got the error: network-manager is not running. But adding the service to sys-firewall / sys-net don’t work. Maybe because of this my wired connection is not working. Can anyone help here?

Try to boot your Net-VM from an ISO (USB).

  1. Clone Net-VM into Net-VM clone 1

  2. Give it 2GB Ram and USB hardware.

  3. Start Net-VM with Parrot ISO (it has a lot of drivers).

  4. If the wired connection works there are a few Parrot (Qubes built) around. Or use your favorite ISO.

You can try to boot into Parrot (without Qubes) to see if it recognizes the correct drivers and wired works.

1 Like

Thank you, I defintely will try that.
But first of all I like to create a debian based sys-net. My standart sys-net atm is a dispvm fed-32 from a fresh qubes 4.1 alpha install. And I only can switch beetween whonix dispvm and fed-32-disp-vm. Maybe that is a problem,too and debian can handle the drivers better ,too?

I would like to add that the killer network hardware has trouble working (or not working) under the new fedora kernels. My E2400 Gigabit Ethernet killer only works when I leave the fedora 32/33 kernel in the old versions. So I have a special template for sys-net-ethernet with the old fedora kernel

1 Like

that would be best and fedora should fix it like in the older kernels. At start the wired connection in sys-net is marked fat black and you think that everything is working and it recognizes the killer, because I can see the name of it at the sys-net popup box, but after a few seconds all my hope is destroyed by the messages the network is disconnected :smiley:
Changing the kernel from sys-net to an older one doesn’t change anything. Just booting with kernel 5.4.98 is working wired, but the complete system have to boot with this kernel. otherwise it is not working.
Like I told u I try to set up my sys-net on a none dispvm debian-10 and it works, but has the same error with the wired connection. So the next step I will try is with the parrot .iso / template. Yesterday I downloaded the .rpm from umman for qubes 4.0 but there was a installation error with some ids and first I need to build it again like the parrot doc says.
Downloading a parrot iso and boot the qubes from cd-rom is not working, like I tried it until now. But I will try it with the commands and and other iso later again. I get the error messages that qrexec 60 seconds cannot start or sth. like that. Maybe it is like a windows-hvm and I only need to set up it to 300+ ,but I did not test it,yet.
Thank you for help and enjoy ur eastern :slight_smile:

I’m not very experienced but when I realized this problem (which is exactly the same with the Ethernet; “network disconnected” when it didn’t even manage to connect) I reinstalled all QubesOS and I was careful to leave Fedora32 not updated, to install Fedora 33, to change the other VMs except sys-net, it work for now

1 Like

that is exactly the problem and device is not managed, too. Okay then maybe a reinstall will be the a solution :slight_smile: and then I should not update the fedora-32 template ,install the fedora-33 and set sys-net ,sys-firewall to fedora-33 template ? And make the fedora-33 as the main global template,too and the running dom0 update for the kernel 5.10…and else and then it maybe will work? :wink: I am thankful for any advise and I am not an expert,too . certainly no problem :slight_smile: thank you again. I think I will try a fresh install later/ tomorrow and take care about ur steps and hopefully it will work then.

If you install fedora 33 and you update it, you will have the same problem. the problem comes from the change of kernel it does not come only from fedora 32. I’m not on ethernet anymore unfortunately but thinking about it maybe the QubesOS kernel has something to do with it too.

1 Like

so sorry it took a a while, but now I can say that it have to be the qubes kernel 5.10+ or even 5.9.14 that makes the problem.
I installed a fresh qubes 4.1 first with debian-10 default template and then only updated the stable repo of dom0 and no template, but it is not working. After updating the templates the same problem exists. It is really strange that for a short moment the connection is recoginzed and u think it is working, but then it disconnected. Then I tried an other fresh install with fedora-32 as default template, because at debian-10 there neither wlan or wired is working for me with the newer kernel. Of course even this time I did not update the template and just dom0 for the new kernel and some fixes, but unfortuntaley the same problem exists. Changing the kernel from the template of sys-net to an older doesn’t change anything. So the main problem should be that the qubes kernel affects the problem. It is not really a driver problem beacause the name of the killer and else is known by the system and the wlan is working. Maybe I can set up my network connection anyway that it will be working, but there I am not expierenced enough. The next step I will try is to install a parrot template on my qubes and try to use this a as a netvm. Maybe I have luck then, but I think not, because the qubes-kernel is running in the back. But maybe :slight_smile: I will ty it , but last day I had some problems to set up the parrot vm and the old .rpm file from umman here unfortuntely has the wrong id and cannot be installed on 4.1, so I have to build it like the parrot documentations says first and had not the time to try this. But in a nutshell it will be very great if the team of qubes can fix that in the kernel and I am sure they will do it, if it is possible:)
I will update again as soon I tested parrot. Testing parrot without qubes I think certainly will work, cause on nearly every system my network card is working that is just a problem since the newer kernel, but I defo need to fix that anytime, because these kernels are the next longtime support and the base for gpu and else, which I like to get working within the time:) Then I will have a secure and powerful qubes ,like I prefer it for my daily uses. But this for sure will take some time hehe.

I also have a Qualcomm Atheros network controller and it doesn’t work with anything above kernel 5.4.98.
I would be glad if someone could help with a solution. For now I am fine with 5.4.98 but it doesn’t look good with future kernels.

1 Like

that is exactly what I noticed ,too. Not good hehe :wink: In kernel 5.9.14 wlan is working and in kernel 5.10.21, but all other newer kernels 5.10.25 , 5.11 and else my whole system is not booting and hangs at boot screen like I told in other threads here. I am fine with kernel 5.4.98 or 5.4.67 ,too doesn*t matter for me what kernel of this versions I will use. Maybe some newer kernel like 5.8 will work, too but that is not the sense. It have to be a kernel 5.10+ or a I need a new ethernet card the next time, that shouldn’t be the problem.

If I need / like to buy a new ethernet card can anybody suggest one that fits for the new kernels and Windows 10 ? Shall I use the killer for my windows system and buy a second (maybe usb) card or replace the old one with one that fits to both systems?

So finally I decided to buy a new usb network card and give it a try.
I am using the one from ugreen now here.

and finally kernel 5.10x is working and I can use my wired connection again. Now I just need to fix the wired display of my templates again and everything is running fine. It is not a fix for the killer ,but if u like to use cable network and have compatibilties problems like me, I think the 15 e are not too expensive to get it working again.

1 Like

Has anything changed since May? I just installed 4.1b and my E2400 doesn’t work. I had to roll back to 4.04.