Qrexec not able to connect to any HVM


I am new to qubes, so please don’t laugh. I think the solution to my problem may be obvious to you, to me unfortunately it isn’t. I have tried to set up a HVM for installing Windows on it using a DVD-ROM and a USB Drive. In settings I set the system memory to 60 Gb and RAM to 8 Gb, then used the ‘Boot from CD-ROM’ to install Windows on it. It worked fine and now Windows 10 is running inside the stand alone HVM.

However, when i tried to assign/connect the USB-DVD-Drive via sys-usb to the HVM I got the error message “Error connecting [name of device] to [name of HVM] failed. Error: QubesVMError - Domain [name of HVM]: qrexec not connected”

How can I connect qrexec, so that the external USB works for the HVM? Btw: this seems to happen to on all HVM’s regardless whether there is Windows on it or not. I don’t want to assign an extra usb-controller to the HVM, because this way, i would only be able to run one HVM.


I’m not using Windows, so I’m not sure if this will work, but you can try the following:

In a dom0 terminal:

qvm-features <Windows qube> stubdom-qrexec 1

Restart your HVM, then try connecting your USB device again.

1 Like

Thanks, that worked perfectly. I could assign the USB drive to the HVM-Windows-qube and it showed up in Windows without an additional USB emulator. However, I have one more question: does the activated qrexec somehow pose a security risk or compromise my system?

None that I’m aware of. If I remember correctly, the only thing that was reported was a slow environment due to the continuous stream that some USB devices require.

You might be interested in reading this: