Qnap NAS Accsess

I am having trouble accessing my Qnap NAS using Fedora Template can someone please help me, I have now got my head around installing from Templates but this
is beyond my knowledge, I am a 72 year old who has just discovered Qubes and loves it, but needs help, please.

Are you trying to access your NAS from Fedora TemplateVM (e.g. fedora-38-xfce qube) or from AppVM based on Fedora TemplateVM (e.g. from personal qube)?
There is no network access in TemplateVMs by design.

I am using the personal qube and Thunar however when I put in my
IP Address nothing happens i’m not sure of another method to connect
to it.

Thanks for you reply

Try to access it with smb:// before IP address:


You can also check samba connection from terminal:

smbclient -L x.x.x.x

Thanks again but neither of these option work still no access
to the Qnap NAS

This is not really a qubes issue but I had to install a package to access my NAS through Thunar GUI. I haven’t tried it in a while but it might have been this one.


An issue I have with this method is file transfer speed is low, like 9 mB/s. I’d be curious to see if you experience the same. I think there’s a proper cli way with high speeds for mounting an smb but I have yet to try it.

What’s the output of this command?

smbclient -L x.x.x.x

Can you ping your NAS from the qube from which you’re trying to connect to samba?

ping x.x.x.x

Are you able to connect to your NAS from some other Linux OS? You can try to boot from Fedora Live USB and check it there.