Q4.2 and i3 4.22: right click issue

Sometimes - I have not found a pattern yet - the right click stops working in Firefox. I can open the right click menu on the tabs, the address bar and all the menus, but not on the web page itself.
It is not template related, because it happens with Fedora or Debian.
Any idea? Thanks!

That’s odd, if this happens it should be for all context menus, not just the one on the webpage. Can you make Firefox a floating window and then try to open the context menu on the right side of the window to see if you can see it appear behind it? Have you tried a complete restart or reload of i3 before this happens?

I made Firefox a floating window, and the context menu is not opening in the background.
The behaviour is erratic: right now, I have a Debian AppVM in which I can open the context menu on the tabs, bars, etc. but not on the web page, and a Fedora AppVM in which the context menu is not opening at all.
Since I just switched to i3, it is very possible that many applications could be concerned, but I just saw it in Firefox.

I don’t recall having this problem on i3 4.22. The closest thing I got was the context menu going behind the window after a restart/reload of i3, but I never got anything similar to you since I started using i3 on Qubes. I’m currently running the 4.23 version, which is not available in the repository. Maybe you can try to build it and see if that changes anything to the behavior you are seeing.

Do you, by any chance, have a setup with multiple monitors? Maybe the layout is not handled correctly by i3 and the context menu appears somewhere out of sight?

New development: I could’t right click on the status bar icon, except network. And immediatly after that, I couldn’t use Super+1, Super+2, etc. I had to scroll the status bar with my mouse scroll wheel to reenable it.
I have a fresh 4.2 install with no modification inside dom0, except i3. Only my AppVMs are restored from a 4.1 Qubes install.

I originally planned to stick to the version provided by qubes-dom0-update, but in last resort I will upgrade to 4.23. Not sure it will solve my issue if it is Qubes related…

I don’t have multiple monitors. Just one with 3440x1440 resolution.

EDIT: I was using i3 after switching from XFCE. I am trying it just after a reboot. No problem so far… I should have begun with that.

Do you mean that you didn’t reboot after installing i3, and now that you have, you can’t reproduce the context menu problem? If that’s the case and after you tried it for a while, you should probably mark your answer as a solution.

I thought so, but it is not XFCE or reboot after i3 install related, after all.

I found a way to reproduce the issue: it happens when I edit .config/i3/config and reload i3 conf (with Super+Shift+C/R).

That’s close to my first thought then. This is what happens when you reload the configuration unfortunately, and the only way to fix it that I’ve found is to restart Firefox.

Maybe will we get a fix for it. At least, I know what causes the issue.
It is not only about Firefox. Several icons disappeared in the status bar, and I had glitches in some apps.

Thank you for your help!

1 Like