Proper way to update EOL templates and disp-vms?


I love qubes. Been using for about a year no problems.

But I saw that my templates are outdated after reading qubes blog. So I try to upgrade from fedora 34 to 36.

Once I downloaded the fedora 36, I tried to change all templates to this. Such as sys-net, sys-usb, and the templates setup during qubes install such as work, unsecure.

First my VPN qube broke. It is an OpenVPN qube connected to fedora-34. I created this qube following these instructions months ago: Using Mullvad VPN in Qubes

When changing to fedora 36, it no longer connects. I am guessing there is something missing that was removed from 34 to 36. But I’m not sure how to check.

One thing I noticed is I went to terminal to check the old files I created following the guide. So I used command gedit, and now that seems to be missing. So I’m assuming more dependencies are missing but I need help finding what’s missing.

Other than that, my sys-usb, which using the disp-vm also doesn’t seem to work. I tried everything to get the mouse working. Is there some special way to update the disp vm? I just changed in qubes manager as I did the other templates. After about 2 hours I gave up and reverted the qubes back to 34 because I need the system for work.

Thank you for qubes and thank you for the help.

It’s hard to tell what exactly is missing (firmwares?), but as an example this is what I did when switching from 34 to 35 at the time in one case:

When I was switching from f35 (minimal or not) to f36-minimal I had to apply many tweaks and install many packages and frimwares, to recreate connections, etc…
So you have to investigate each case independently

Although you don’t use minimals, probably this page is good start point to check if you have minimal requirements packages installed in your f36.

Or you could wait for f37, since I read on a github devs are working on it soon.

And most important thing, now you take notes about it.

1 Like