Problems copying/moving files from one appvm to another in qubesos 4.1

I’ve been trying to move a file from my work vm to my vault but got this message

qfile-agent: Fatal error: File copy: “Unknown error 993024795” (error type: Unknown error 993024795)

I also tried to look for solution online, but found none

p.s I’m noob in qubes

Is this problem only with one specific file or you can’t transfer any files to vault?
Can you transfer files to any other VM except vault from work VM?
Can you transfer files between any other VM except vault and work VM?

The problem is with every vm and template.

Did it work before?

Yes 5 days ago when I needed this kind of operation…
Since then I’ve had updates including dom0

Can you check if the output of the command below, matches the default policy:

cat /etc/qubes/policy.d/90-default.policy | grep Filecopy
qubes.Filecopy          *           @anyvm          @anyvm      ask

Also, could you check if qvm-move works instead?

Qvm-move doesn’t work,
and this is what I got after running the command

cat: /etc/qubes/policy.d/90-default.policy: No such file or directory

Did you run this command in dom0?

No, I run it in the work vm.
After running it in dom0 I got this

qubes.Filecopy * @anyvm @anyvm ask

This problem may be related to some failed updates.
You can check these files in dom0:


And search for err or fail strings and see if some packages failed to install.
Also did you try to update your dom0 and templates? Do you get any errors when you try to update?

I entered the commands and found now errors

Also, I tried to update dom0 and the templates today , even though I had no update notification.

Try installing a template that you don’t have (like debian-11-minimal, fedora-35, or any template that you haven’t installed yet), then make two AppVMs based on that new template and try to qvm-copy a file between them.

How-to guides: