Problem with keyboard input detection in Dolphin emulator inside fedora 36 qube

Qubes 4.1
Keyboard and mouse input via PS/2.
Inside my fedora 36 gaming qube Dolphin standalone emulator fails to register keyboard input. The only input device it lists is “Xinput2/0/Virtual core pointer”.
In Retroarch input works fine, it is listed as “x”. I’m using standalone dolphin because retroarch core doesn’t load.

What kind of emulated input does Qubes present to the vms? I’ve tried viewing /proc/bus/input/devices inside a vm, it only lists “PC Speaker”
/dev/input lists “event0” and “mice”

Is it possible to redirect whatever emulated input format qubes presents to vms into a format recognized by dolphin?

After digging further I found that Dolphin supports the following Input APIs: DInput, XInput, and SDL
tho it should also support Xlib as there are some users who have Xlib/0/Keyboard Mouse
So I guess this should be the case in a default fedora template as input is managed through the x11 library? retroarch shows x as its input, so I guess this x11 library is working? but Dolphin still can’t detect this input somehow?

xorg-x11-drv-libinput package is installed by default
tried installing xorg-x11-drv-evdev - still no difference

Ok, so after reading about XInput it looks like it uses Xlib to manage input? Well, whatever the case, the command “xinput” in my fedora cube lists the following:

Virtual core pointer id=2 [master pointer (3)]
Virtual core XTEST pointer id=4 [slave pointer (2)]
qubesdev id=6 [slave pointer (2)]
Virtual core keyboard id=3 [master keyboard (2)]
Virtual core XTEST keyboard id=5 [slave keyboard (3)]

So Dolphin registers “Xinput2/0/Virtual core pointer”, but not “Virtual core keyboard”, I guess because Virtual core pointer has qubesdev as its slave, while Virtual core keyboard master has only Virtual core XTEST keyboard as its slave, which is for testing purposes I guess.
So what is this “qubesdev” device? And why is it only in the mouse master? If keyboard input is handled by XInput, how does it register my keyboard keystrokes when xinput shows that it only has XTEST as its slave?