Problem with accessing CUPS in debian template

I am trying to set up my network printer following the instructions at Configuring a network printer, with no luck. FWIW, i can print to it fine from my Linux Mint PC, no special config required.

I am doing all of my testing in the debian template. I start Print Settings, and when I click the Start Service button, it greys out for a few seconds and then becomes active. When I click the Connect button I get a “failed to connect to server” error.

I confirmed that cups is not running. This is new territory for me since it works out of the box on Mint. Any suggestions?

Possibly related, I see this on the console when I run system-config-printer:

user@disp1069:~$ sudo system-config-printer

( Gdk-CRITICAL **: 19:41:57.596: gdk_atom_intern: assertion ‘atom_name != NULL’ failed

( Gdk-CRITICAL **: 19:41:57.597: gdk_atom_intern: assertion ‘atom_name != NULL’ failed

ok, I found that I had to add the cups service to the qube (not template) I want to print from. That worked, however now I need to figure out how to add the printer to cups. Is there any way to auto-discover printers, like in Mint?

I went to Network and entered the IP address of the printer in Host. I was able to add the printer, but I don’t think it is quite right since the test page failed and gave me “client-error-document-format-not-discovered”.

Is there some additional step I need to do to get printer discovery working? I’m assuming that since cups on Mint can do that, there has to be a way to get it to work in a debian qube.

I managed to get the printer working by just trying different options, but that was painful. I hope I am missing something obvious that would make this much simpler.

Visit localhost:631/admin with your browser in the VM where cups is running and do your configuration there.
Afterwards copy the cups configuration at /etc/cups from that VM to the template to make it persist.

I used the Print Settings in my app config to configure the printer, instead of the web method. I copied printers.conf to the template, and now the printer config persists and it is working.


I suspect there are a lot of business and individuals that have network printers. It would be nice if this information could be documented in a how-to of common post-install config tasks.

I also wish that the cups configuration was as automatic as in Linux Mint. Mint both found the printer and determined the printer config to use all by itself.

And if I am dreaming, it would be nice if there was a wizard for cases like this where config has to happen in an app vm, but the resultant files need to be moved into the underlying template. Maybe launching an app in a “config” mode, where it offers to move modified files to the underlying template.