Problem booting qubes after moving internal nvme to external usb

Hi all.
as in topic, I’ve had to move previous internal nvme to usb case.
On it a dual boot MS+Qubes.
Now starting from recovery, I’ve tried as reported in:

but no luck.
At boot, still bios answer me that no bootable partition found using added uefi entry.
Any other ideas?
Thanks a lot.

Maybe you’ve created UEFI entry for wrong partition?
But anyway, with removable disk the UEFI entry that you create won’t be persistent and it’ll be removed if you boot your machine without your Qubes OS USB disk connected.
Do you have Qubes OS 4.1 or Qubes OS 4.2?
For Qubes OS 4.2 with latest updates it’s no longer needed to add uefi entry and you can just boot using the USB disk UEFI entry:

If you have Qubes OS 4.1 then you can create fallback boot path for UEFI as described in the issue:

  • Mount the bootloader partition
  • Copy the contents of /mnt/EFI/qubes/ to /mnt/EFI/BOOT/
  • Rename grubx64.efi to bootx64.efi
  • Rename grub.cfg to bootx64.cfg

Hi and thanks for your answer.
I’m still onto 4.1.2
I Don’t know if it’s my case, but: I’ve tried everything.
first boot partition of usb case, the qubes boot device, the encrypted one and with and without usb key plugged in , used to boot.
No luck.
Always same response from bios: no bootable partition.
In usb case that’s the layout
sda1 (efi)
[win stuff here]
sda7 /boot
sda8 /root (encrypted)
Thanks a lot.

Did you try this?

On second thought, since you’re dual booting Windows and Qubes OS from the same USB drive then you can’t use fallback UEFI boot path for Qubes OS since it’s already used by WIndows.

Hi and thanks for your suggestion.
I’ve yet renamed win-one bootx64.cfg in .old and replaced it with qubes, as in the procedure You point-to, but still doesn’t boot.
Of course in my bios:

  • disabled secure boot
  • enabled audit mode (instead of enforcing one)

I know, it’s basic setup, but just to let You know I’ve tried anything.

During my tests someimes I see for less than a sec the grub screen, but immediately after it, the hated bios message: no bootable partition.

Thanks anyway.
Cheers,
M.

How did you move your internal NVMe to external USB?
Did you move it physically from your laptop to the external case with NVMe-USB adapter?
Or did you get USB disk and dd the partitions from your internal NVMe to this USB disk?
In case of dd, did you dd separate partitions or whole disk?
Check the USB disk partition table scheme, is it GPT or MBR?
It should be GPT.

I’ve physically moved (not cloned) and yes, disklabel is GPT.

hi all.
so?
unable to boot… ok…
but if I reinstall from scratch, will be the same?
thanks.

Maybe you have disabled booting from USB devices in BIOS?
But since you’re seeing the GRUB blink sometimes then it may not be the case:

Are you able to boot in Windows on this external USB disk?

Yes I can normally boot Windows.