Problem booting CPU cores while installing Qubes OS


I’m currently having some trouble installing Qubes OS. I’m trying to install Qubes R4.0.4 on a Legion 5 15arh05h (not listed on HCL) with AMD Ryzen 7 4800h and Nvidia Geforce 1660Ti, with AMD-V (SVM) enabled.

At first I was getting the “Not asking for VNC because we don’t have a network” / “X startup failed, aborting installation” / “Pane is dead” error on UEFI during installation. I verified the integrity of the ISO and tried making a USB stick using both rufus and dd method and switched to legacy boot mode and tried but I kept getting stuck on a black screen. I tried the solutions mentioned here, but none of them worked, then I tried the “Install Qubes R4.0.4 in basic graphics mode” under troubleshooting menu and it got me further. I’m now getting the following error:

“(XEN) Not responding”
“(XEN) Failed to bring up CPU i (error -5)”

It prints it for all the available threads of CPU (i from 1 to 16), indicating that the installer cannot successfully boot up the cpu cores. I looked it up but no topics came up. I was however able to find it in the github source codes of Xen, in case it might help with the troubleshooting somehow. it is apparently generated by /xen/arch/x86/setup.c which prints the return value of cpu_up():
which gets its value from either cpu_notifier_call_chain() or __cpu_up(), but based on the 5 second delays I’m getting between each error line and the error code which is -5, which based on the errorno.h translated to I/O error (in ARM version it is explicitly returns -EIO, which is -5), I’m guessing it is generated by __cpu_up().

Any ideas on what’s causing the problem and how to solve it?

Update: I have tried the workaround mentioned here for AMD APUs that have a similar problem with XEN installers by setting maximum memory of dom0 to 2048M and it didn’t help solve the problem either.


Your hardware might be too new for the old Qubes 4.0 Linux kernel. Did you try 4.1?

I’m currently downloading R4.1.0-beta1, I’ll try to install from that and I’ll update you with the results.

Update: R4.1.0-beta-1 produces the exact same result. If my understanding is correct, Qubes OS has used the same version of Xen since 2014, so if this has to do with the version of Xen, R4.0.4 and R4.1.0 wouldn’t be any different in this regard.

We discuss problems with 5800H here Qubes 4.1 on Legion 5 pro R7 5800H RTX3060

You can join us there, if you want.

1 Like

Xen updates regularly. There are 13 stable versions since 2014. It is expected that Zen3 processors will be fully supported in v4.15.