Problem activating VT-d in BIOS

This concerns a Gateway Notebook laptop (model number GWTC51427-BK) with 8GB Ram and a 512GB SSD. It has an Intel Core i5-1235U Processor, Quad Core (12th generation). To try to enable virtualization I used this link :

In BIOS, under “CPU Configuration”, there is no option listed for enabling VT-d. VMX is enabled by default. I’ve looked all over BIOS and can’t find any listing for VT-d.

I called up Intel and they confirmed that the processor is VT-d compatible. I called up Gateway and they said that no changes can be made to the BIOS settings.

I tried to download the Qubes ISO as per the instructions and it didn’t work. Based on all of this information, is it possible to install Qubes OS on this laptop? I’d appreciate any feedback.

1 Like

You can try installing Qubes OS on another computer and move it to your laptop. It was done several times and documented on this forum. You can try Gateway forum or some BIOS forum… If you can’t find an answer I recommend Kaisen OS (very good!)

But does the motherboard support VT-d?

@fsflover is right. Your CPU, BIOS and chipset all have to have VT-d support.

@intelscan, if you can answer a couple of questions, we’d really be able to give you much better answers:

  • What happens when you try to boot from the Qubes OS ISO?
  • If you can boot into the installer ISO (or boot into any Linux-based OS that gives you a shell, really), can you post the output of lscpu and lspci?

That’ll likely give you a definitive answer :slight_smile:

1 Like

I called Gateway and asked if the chipset is VT-d supported. After checking with the technical staff, the support rep said that VT-d isn’t enabled in BIOS. I asked him a couple of times if the chipset supports VT-d but he wouldn’t give a straight answer to that question. He said that VT-d comes in through BIOS itself and emphasized that VT-d is not enabled in BIOS and that the BIOS settings can’t be adjusted.

Nonetheless I tried to download the Qubes ISO again and succeeded. Long story short, I was unable to boot into a USB drive through Rufus. Based on the Gateway rep’s testimony, my corner has thrown in the towel. Thanks for all the replies.

1 Like