Probem With Qube Manager - two tray icons


I don’t know how but it magically appeared on my top bar 2 Qube manager icons.

They appear after every restart.

Do you have any idea how I can fix it?

If you’re using Xfce version of desktop under Qubes (default & highly likely), you could try to change (say enlarge to test theory, leave that way or change back) the notification icon sizes (by altering something in the notification properties which can be difficult to access directly by right clicks without hitting other things or maybe dug out of the general Xfce GUI dialogs for configuration).

I have noticed that you can expect sometimes either an empty or useless icon graphic for some things when the size is set too small - that fix once you increase the size & allow things to redraw. The useless icons are often leftovers I guess from failed draws using whatever happens to be in the buffer?

I get these as well in R4.0 with XFCE. Both icons are are clickable with full dropdown menus. Resizing hasn’t worked to get rid of them.

1 Like

Maybe instead I should recommend checking into your Notification Area dialog? Are there two separate Qubes Managers listed in either of yours (mine shows a single Qui-domains under Known Applications that likely relates)? Perhaps one extra got into that list (possible that there is a text file config somewhere that we can learn to edit that out)?

No, there’s only 1 Qui-domains listed in the notifications area. Toggling it on and off still shows the dual icons. This behavior showed up several weeks ago after some updates. I don’t normally mess with the notifications area or the panel, so this seems to have been the result of an XFCE or dom0 update at some point.

Sometimes it goes away (goes back to 1 icon) and then comes back between reboots, but I haven’t bothered to research this.

Exacly like pr0xy said, the issue appeared on my desktop in the same way.

I tried to change the size of the icons and bar settings without success.

do you have any other ideas?

Other than recommending a tiny reset (don’t panic, this one only affects your Xfce desktop configured settings rather than all of your Qubes & isn’t a reinstall), perhaps you will need to file a bug report (github?). The session info can be forced to clear & you can perhaps set the record straight with Xfce (it may have a corruption that we just don’t know enough about to resolve).

Before that, someone may want to verify that while the two icons are visible & both react does task manager display two instances of the qui-domains script (mine shows path to python before the path to the script - like this, /usr/bin/python3 /usr/bin/qui-domains) as this may be a good time to determine that for completeness before clearing session & before posting a bug report. If the script starts more than once (shouldn’t, but hey, what you’re experiencing shouldn’t either), perhaps that would explain the double up.

If you think session info may be corrupt, then in the Xfce tools there is a dialog for Session and Startup which has a tab for Saved Sessions. I don’t usually clear mine but here is a place to start - unsure how it would fully work except to share that logging off with a check mark in a specific place can lead to saving current session info which is practical to perform once after you rearrange everything before then unchecking that check mark (I believe that it is only accessible once you setup Action Buttons to allow the display of Log Off with the … option that displays a multi-button dialog when logging off which contains that check box).

Anyone else out there have any suggestions? Maybe search Qubes github for similar tickets beforehand?

Interesting. I booted into KDE Plasma and the dual icons show up there as well.

1 Like