Printing services not available since migration to v4.2

I had my network printer configured with system-config-printer in a fedora template with v4.1 and the printer worked. Since (inplace) migration to V4.2 there‘s no printer available anymore and I can’t connect to the network printer using system-config-printer.

Any ideas?

First, make sure cups is installed in the template (to check: rpm -qa | grep cups / to install: sudo dnf install cups). Then add the cups service to the qube settings where you want to execute the print request.

1 Like

As @DVM pointed out, you have to enable cups in the templates now - I’m not sure why it’s not enabled by default, but I ran into the same thing.

You can do, from a dom0 terminal:

qvm-service --enable <VM> cups

Or, if you prefer the GUI, go into Qubes Manager, select your VM and enter settings. Go to the Services tab. Select ‘cups’ in the dropdown list and click ‘add’ - it should then start the service on next VM start (I think you can go in manually and do it too, but it’s usually just as easy to restart the AppVM).

1 Like

Thanks @Syonyk . Enabling the service helped.

If I remember correctly I haven’t enabled it in v4.1 but it still worked. Do you know what changed for v4.2?

It used to be enabled by default in every single qube. It was removed in 4.2 after this issue:

1 Like