Policy: equivalent of 'ask,default_target=xyz' in 4.1?

In 4.0 I used to have the following rule in /etc/qubes-rpc/policy/qubes.OpenInVM:

$anyvm $anyvm ask,default_target=dispBrowser

This rule filled the “ask popup” dialog’s destination vm with ‘dispBrowser’ (a named dispVM I use for browsing the web). It’s a time saver - no need to spend time choosing the same VM 90% of the time - and is much less error-prone too - eg. avoids selecting the wrong dest vm by mistake.

I’m now trying to do the same in 4.1 but no luck. The current policy documentation is still for 4.0 and the the New Qrexec Policy System article wasn’t helpful.

Any idea how to do this in 4.1 without using compat rules ?

Thanks !

It seems to be working for me. Could you be more specific with “no luck”? What’s happening? Any errors in journalctl -f?

1 Like

Oh - reading that it was working for you I just tried with ask default_target=dispBrowser and voila, it worked. I was pretty sure I had tried that combination yesterday but looking at the logs I’ve used a comma instead of an interval (despite knowing that the new policy uses intervals). Lack of sleep I guess :frowning:

Sorry for the noise; thank you for taking the time to test/reply !

1 Like

In fact, not accepting coma in the old policy location is a bug - old policies should work unchanged too.

1 Like

(in my case it was a 4.1/5.0 policy in the updated location - /etc/qubes/policy.d/30-user.policy)

right, .policy files do require space instead of coma.