PLS HELP broken qubes-> qvm.usb-keyboard + start sys-usb = BLANK SCREEN :(

Was trying to get Yubi key to work.
Followed what user did here-> YubiKey not Detected in Device Manager (USB-keyboard enabled) - #23 by whoami

Entered command " sudo qubesctl state.sls qvm.usb-keyboard ", then went to Qubes manager and started usb qube

Black screen…

Rebooted, could unlock drive but before login screen blank screen again.

As an aside: Using Nvidia GPU and USB kb + mouse.

Is there any hope at fixing this and getting back my qubes install ?
How do I undo whatever that command did and stop sys-usb from starting ?

Pls pls pls help, thx.

Managed to get back into qubes os buy adding " qubes.skip_autostart" to grub.

However, I cannot use any USB device anymore + I have to manually enter “qubes.skip_autostart” every time I boot my machine.

How do I restore USB function without losing my monitor and have it boot without having to manually enter things into grub?

1 Like

remove rd.qubes.hide_all_usb in grub…
Like in the doc :slight_smile:

Thanks for sharing, however → I do not have an entry in my grub at all for rd.qubes.hide_all_usb

BTW: What is in the document you linked?

Any other ideas for how to repair?

Are you sure? Recheck it in dom0 terminal:
cat /proc/cmdline | grep hide_all_usb

It should’ve been this link:

How to remove a USB qube

Warning: This procedure will result in your USB controller(s) being attached directly to dom0.


  1. Shut down the USB qube.
  2. In Qubes Manager, right-click on the USB qube and select “Remove VM.”
  3. Open the file /etc/default/grub in dom0.
  4. Find the line(s) that begins with GRUB_CMDLINE_LINUX.
  5. If rd.qubes.hide_all_usb appears anywhere in those lines, remove it.
  6. Save and close the file.
  7. Run the command grub2-mkconfig -o /boot/grub2/grub.cfg in dom0.
  8. Reboot.

Addionally, please check your USB connection:

When using a USB keyboard on a system with multiple USB controllers, we recommend that you designate one of them exclusively for the keyboard (and possibly the mouse) and keep other devices connected to the other controller(s). This is often an option on desktop systems, where additional USB controllers can be plugged in as PCIe cards. In this case, the designated controller for input devices should remain in dom0 but be limited to input devices only.

1 Like

And vote for this enhancement issue with a comment or emoji.
I think it would be helpful in case of 90%+ of problems related to usb qubes and other cases in Qubes OS.

1 Like

Thanks. Followed steps, edited grub, and made new grub config.
System boots without fault. Just one question:

It is now not recognizing any USB devices.

How do I make it recognize USB devices as it did previously + also recognize Yubikey without black screen (nvidia gpu) or loss of kb&mouse ?

I guess you need to remove usbcore.authorized_default=0 option from your grub config as well:

Qubes 4.1 only: You should also add the usbcore.authorized_default=0 option, which prevents the initialization of non-input devices. (Qubes ships with a USBGuard configuration that allows only input devices when usbcore.authorized_default=0 is set.)

Do you have Qubes OS installed on USB drive?

1 Like

I removed that line from Grub cant get USB storage devices to be detected.
Connect USB devices, not autodetecting like previously.

This whole mess started when I followed the guide for setting up a Yubikey. I would love to be able to use USB storage / Audio / Yubikey.

How do I do that I am utterly lost?

Did you make a new grub config with grub2-mkconfig after you removed usbcore.authorized_default=0 in /etc/default/grub?
Or maybe you still have old EFI grub.cfg instead of unified one and then you need to update it instead:
grub-mkconfig -o /boot/efi/EFI/qubes/grub.cfg

Do you have external display connected with USB? Maybe you have this issue:

1 Like

I have this issue, as soon as sys-usb started or I followed steps to enable usb devices my monitor goes blank can see my GPU flashing that it is not in use.

However I am using HDMI/DP no USB Video here, the issue linked is for someone with a USB monitor.

Just want to be able to use USB storage/ Audio / Yubikey, is it too much to ask ?

:slight_smile: I am open to ideas becuase this is killing me, pls help.

Could you please comfirm this.

I had a USB hub issue in the past that was fixed by simply switching the USB devices. Is your USB keyboard and USB Yubikey on the same USB hub? What is your USB setup: All connected without adapter and hubs directly to a separate USB connector?

It could be a to a bad power supply since you have audio, storage, keyboard, mouse, yubikey connected.
But I doubt this since audio and storage could have a high power request but Yubikey almost nothing.

Anways, it is worth to disconnect all apart from keyboard, mouse and Yubikey for further debugging.

I have unplugged all USB devices, besides kb & mouse.
Then unplugged kb and inserted usb storage device in its place.
No detection in device drop down of the usb device.

How do I get any storage or Yubi usb to work ?

maybe a separate thread is warranted for this

Did you make sure that you don’t have usbcore.authorized_default=0 in your kernel options?
Double check it in dom0 terminal with this command:

cat /proc/cmdline | grep authorized_default
1 Like

For some reason it did not overwrite efi file, did it again, and it did.
Usb storage devices work.
Yubi key absolutely does not work or appear in devices.
Any ideas how to get non block devices, like this Yubikey to work ?

I don’t know if there’s any way to make it work without sys-usb, but I’d still try to create a working sys-usb and find the source of your problem with sys-usb and display blanking.
Maybe you have multiple PCI USB controllers that are attached to sys-usb after creation and only one of them could cause your problem with display, so I’d try to create sys-usb in the same way as before but remove all USB controllers in sys-usb Qube Settings → Devices tab except for one USB controller and then try to start sys-usb with each USB controller separately to try and find the one that is causing the display issue.

1 Like

Yes that absolutely sounds like what needs to be troubleshot.

  1. To make absolutely certain that I am setting up sys-usb correctly what steps do I need to take, what kind of qube should it be / setttings / anything to do on command line
  2. Do I plug kb + mouse into that same single controller I am testing.

As an aside I see only two USB: xxxxxx controllers one for 3.0 and one for 3.1 however I have 2.0 ports as well. Does this change the surface of how many tests I should be doing and how do I locate the 2.0 controller ?

You can follow these steps:

It doesn’t matter, kb/mouse should work anyway.

If you have only two USB 3 controllers then it could be that you have USB 2.0 hub connected to one of these controllers. You still only need to check these two USB 3 controllers.