Please help. Urgent

I went to my laptop like I do everyday to find qubes is just black and not responsive. I hard reset my laptop and start up took a lot longer than usual. I finally got to qubes home screen and it seems sys net is unable to start. I get error message"domain sys net has failed to start: cannot connect to qrexec for 60 seconds, but see /var/log/xen/console/guest-sys-net.log for details.

I tried manually starting sys net in terminal with qvm-start sys-net and I got the same error message. What should I do?

I can open other qubes like vault just fine.

Did you look in the file /var/log/xen/console/guest-sys-net.log in dom0? - and what extra info did it have? :slight_smile:

You can check the timeout for qrexec with:

sudo qvm-prefs --get sys-net qrexec_timeout

and if you want/need to change it:

sudo qvm-prefs --set sys-net qrexec_timeout 120
1 Like

How do I get to that file? I’m a bit of a qubes noob

In the top left corner of your screen, you should have a “Q” icon - click on it and then click on “Terminal Emulator”. That will give you a shell in dom0. There you can use less to view the file:

less /var/log/xen/console/guest-sys-net.log

You can use

  • arrow keys to scroll up/down
  • q to quit.
  • p to scroll to the start
  • G to scroll to the end of the file

I typed first command in terminal and it just says 60 below it

The default qrexec_timeout is 60 seconds … :slight_smile:

Okay I was able to do that. It opened up and it’s just tons of lines of info. Not sure what I should be looking for.

In the worst case, you can try to simply backup all your VMs (which contain the actual user data), then reinstall Qubes and restore the VMs. You should have a backup anyway, don’t you?

Only thing I have backed up to my knowledge is vault files on a flash drive. I have a fresh qubes install on another flash drive. I don’t have many qubes so re making them from scratch isn’t a big deal however re installing ws16/gw16 is a bit of a pain

Hey guys so weird… It randomly started working again. Wtf? However my clock is wrong so I’m trying to fix that now.

Nevermind… I restarted and it’s doing it again :frowning:

Can’t figure out the issue as it keeps reoccurring. Going back to windows. Thanks for the help.

Without the information from /var/log/xen/console/guest-sys-net.log, it’s difficult to give any advise or guess what’s the reason. :-/

1 Like

This post was flagged by the community and is temporarily hidden.