Please help, unable to reinstall Qubes!

Hey guys, This is my first post to this forum and I’m hoping you can offer me some advice.

tl:dr: I had a Qubes system working for about 2 weeks, but then needed to reinstll and I can’t seem to get it to work at all. Initially on my first install everything ran perfectly bedised a USB issue. I couldn’t get the machine to recognize USB devices like printers, etc.

So, I decided to add a sys-usb hoping it would fix the problem. During that process I followed the guide and tried several times to allow a keyboard and mouse, but after multiple attempts I couldn’t seem to get the Mouse and Keyboard to work dom0 kept saying it was failing. The system kept throwing an error about about a “buffer” and that “sys-net-usb” wasn’t installed. I tried to fix this error for a few days but didn’t get it to work.

Anyways I went for the nuclear option and just decided to reinstall Qubes all together, (I didn’t have much set-up yet anyways), Plus, it had moved from the Alpha version to the newest release by that point anyways.

*Now here comes the main issue. I cannot get Qubes to reinstall onto the same system again. I load the iso or dd usb and it pulls up to the grub menu and after that I get a couple lines of text and the screen dies and its done! The last thing i see is Xen is relinquishing to VGA or something… Its so frustrating because i know it should work on my hardware because it ran for two weeks prior to my starting over. I have tried multiple USB’s, I’ve tried using multiple USB port types I have made usb’s using Rufus and Balena Etcher ans I’ve downloaded several downloads. I even tried ALL of the major weekly update links, the alpha version and the current version I’ve made usb’s in ISO and DD mode, makes no difference. I even opened up an old Librem laptop and it installed everything just fine! So I took the NVME drive out of the Librem PC and put it in the new computer and tries to just restore Qubes and it still wont work. The amount of time I’ve spent on this is embarrassing actually. PLEASE HELP!!!

Maybe I have a setting wrong in UEFI or somewhere? How and where would I get logs to provide to someone to help me trouble shoot my issue?

Basic system Info:
Intel 10900 with integrated graphics, 10 cores, 20 threads
64 GB memory
Supports Vtx/Vtd and I believe IOMMU? The mother board is a ASRock h570m-itx/ac.

Already had this system working once. **ALSO I AM WILLING TO PAY SOMEONE WITH THE TIME AND KNOWLEDGE TO HELP ME OUT AND GET THIS FIXED ASAP!! Hope to hear from you soon.

If someone needs logs just tell me what you need and how I can find then to send to you.

Thank You!!!

can i see the uefi and vt-x and vt-d (iommu) configuration
also text splash when you try to get qubes to boot too if possible

welcome to the forum/qubes.

did you read through this and have any questions? Personally I use a PS2 -USB adapter , some keyboards don’t play well also ; and attaching things to qubes via USB widget can be hit and miss,

are you saying you are using the same installation medium, and can’t boot off of it

historically, it DID make a difference how the installation medium was created at times, with dd being the preference as I recall

$ sudo dd if=Qubes-RX-x86_64.iso of=/dev/sdY status=progress bs=1048576 && sync

To echo what @Clodius is mentioning in this post. @daddycurbcheck, when I tried to upgrade to 4.1rc1, I had problems on the install. I turns out, I either had a corrupted iso file, or the process of writing the iso to usb drive got corrupted.

I had to re-download the iso, then write it back to usb drive. Then the install process worked cleanly for me.

Maybe this is a stupid one, but I noticed several issue with USB hubs / ports. Did you install / boot via USB hubs / USB 2.0 / 3.0… If you didn’t test it already try do remove all unnecessary USB devices / cables and limit it only to the most direct and mandatory.

1 Like

Intel Hyper Threading = Enabled
Active Processor Cores = All
CPU C states Support = Disabled
CPU Thermal Throttling = Enabled
Intel Virtualization Technology = Enabled
Hardware Prefetcher = Enabled
Adjacent Cache line Prefetch - Enabled
Primary Graphics Adapter = Onboard ( I have also tried it on Auto)
Above 4G Decoding = Disabled
VT-d = Enabled
SR-IOV Support = Enabled
DMI Link speed Gen 2
PCIE Link Speed = Gen 2
PCI Express Native Control = Enabled
PCIE ASPM Support = Auto
PCH PCIE ASPM Support = Auto
DMI ASPM Support = Enabled
PCH DMI ASPM Support = Enabled
Share Memory = 1024M
IGPU Multi-Monitor = Enabled
Intel Ethernet Connection I219-V= Enabled
Realtek 2.5G Ethernet Controller = Enabled
Onboard HD Audio = Auto
Front Pane; = HD
Onboard HDMIHD Audio = Audio
Onboard WAN Device = Enabled
Deep Sleep = Disabled
SATA Controller = Enabled
SATA Mode Selection = AHCI
SATA Aggressive Link Power Managemant = Disabled
Suspend to RAM = Auto
PCIE Devices Power on = Disabled
USB Ports = All Enabled
Security Device Support = Enable
Disable Block SID = Disabled
Intel Trust Platform Technology = Enabled
Secure Boot = Disabled
Fast Boot = Disabled

Yeah, Ive tried it in all the ports and the only things I have plugged in is a mouse and keyboard, which I kinda need to navigate. I have also tried several USB types, 2.0, 3.0 and 3.2 C type. I’m confident my downloads and usb’s are fine because I have tested them and they work on other machines.

I’m pretty confident my USB and/or the download is fine. They work on other machines.

Yeah, I’ve been through the documentation extensively. I’ve tried so many ways to get this reloaded its insane. Like I said though, the part that is driving me crazy is that it was working great until I screwed up my sys-usb qube install. All I did was reinstall the OS and now I cant get it past “switching to inteldrmfb from EFI VGA”

So, I have verified that I have vt-x and vt-d (iommu) are active and working. The last thing I see during bootup is "switching to inteldrmfb from EFI VGA” at that point I lose everything…

I’m assuming this is that part you are referring to:?

Change the xen configuration on a USB media

  1. Attach the usb disk, mount the EFI partition (second partition available on the disk)
  2. Open a terminal and enter the command sudo su - . Use your preferred text editor (e.g nano ) to edit your xen config ( EFI/BOOT/BOOTX64.cfg ):
nano EFI/BOOT/BOOTX64.cfg
  1. Change the kernel key to add your kernel parameters on the boot entry of your choice
  2. Install using your modified boot entry

On another note… since I am able to install Qubes on a nvme drive with my Purism machine would it be possible to install everything on a drive in that computer and then take it out and put it in my new computer and 'Rescue" the install using the instructions at the bottom of that troubleshooting page?

Accessing installer Rescue mode on UEFI

In UEFI mode, the installer does not have a boot menu, but boots directly into the installation wizard. To get into Rescue mode, you need to switch to tty2 (Ctrl+Alt+F2) and then execute:

pkill -9 anaconda
anaconda --rescue

i think there

It could even just work, without any need for the rescue. Some people are doing such things with Qubes.

Did you also check that your USB ports are not broken themselves?

I have verified that all of my USB ports are functional. One last thing I may try is burning the USB in dd mode using the slowest USB port my mother board has available, which is still a 3.0 I believe…

I actually installed Qubes OS on a hard drive using my librem computer and then switched it into my new system and couldnt get it to recognize a boot partition so I couldnt figure out how to restore it. Any tips that way?

I’ve also noticed that the grub boot up commands are much longer with my librem machine but a lot of that is probably due to the USB security token it uses as part of Pureboot.

why don’t you turn off “thermal throttling” and the hyperthreading
2- install as uefi only, but also enable legacy support CSM?
3- besides onboard, and auto, is there another choice?