Please help, Error upgrading 4.1 to 4.2

I used the instructions in the Qubes documentation, and everything was working well until I got to stage 4. the first qube it tries to update is my Android template, however the update fails, I get this error message:

and the update process stops/fails without trying to update any other qubes. I would like to finish upgrading to v4.2 as soon as possible. What should I do?
Thanks in advance.

I would externally backup any important files, then do a full clean install of Qubes OS; I did that when I was on R.4.1.2.

I was hoping I wouldn’t have to do that, but that may be my only option.

1 Like

there is a flag to exclude HVM vm from upgrading, I think this is the same issue I had a while ago during a release candidate with an OpenBSD VM :+1: (don’t forget to make backups though)

@solene Okay Thanks, how would I go about doing that?

my bad, you have to skip standalone VMs, not specifically HVM.

This is done by adding -k

Usage: qubes-dist-upgrade [OPTIONS]...

This script is used for updating current QubesOS R4.1 to R4.2.

    --update, -t                       (STAGE 1) Update of dom0, TemplatesVM and StandaloneVM.
    --release-upgrade, -r              (STAGE 2) Update 'qubes-release' for Qubes R4.2.
    --dist-upgrade, -s                 (STAGE 3) Upgrade to Qubes R4.2 and Fedora 37 repositories.
    --template-standalone-upgrade, -l  (STAGE 4) Upgrade templates and standalone VMs to R4.2 repository.
    --finalize, -x                     (STAGE 5) Finalize upgrade. It does:
                                         - resync applications and features
                                         - cleanup salt states
    --convert-policy, -p               (STAGE 6) Convert qrexec policy in /etc/qubes-rpc/policy
                                       to the new format in /etc/qubes/policy.d.
    --all-pre-reboot                   Execute stages 1 to 3
    --all-post-reboot                  Execute stages 4 to 6

    --assumeyes, -y                    Automatically answer yes for all questions.
    --usbvm, -u                        Current UsbVM defined (default 'sys-usb').
    --netvm, -n                        Current NetVM defined (default 'sys-net').
    --updatevm, -f                     Current UpdateVM defined (default 'sys-firewall').
    --skip-template-upgrade, -j        Don't upgrade TemplateVM to R4.2 repositories.
    --skip-standalone-upgrade, -k      Don't upgrade StandaloneVM to R4.2 repositories.
    --only-update                      Apply STAGE 4 and resync appmenus only to
                                       selected qubes (comma separated list).
    --keep-running                     List of extra VMs to keep running during update (comma separated list).
                                       Can be useful if multiple updates proxy VMs are configured.
    --max-concurrency                  How many TemplateVM/StandaloneVM to update in parallel in STAGE 1
                                       (default 4).

Okay, Thanks!

I had the same problem with my “mirage-firewall” VM. Setting the -k flag solved the problem.