Passthrough GPU causes system to restart

Running into troubles, like usual. Sorry everybody for all the posts I’ve been making, just learning a new OS for the first time.

So, I’m attempting to pass-through my AMD GPU in a Window Qube, but every time it starts to run, my whole system goes black, then restarts. My primary GPU is Nvidia – anybody have any advice, by chance?

Did you hide the GPU you want to passthrough from dom0?
Follow the guide:

1 Like

i did hide it, yes. and I’ve follow that, as well.

Do you see the GPU that you’re trying to hide in the list of PCI devices in dom0?


Huh. Yeah, I do. Both of the devices. I’ve rebooted after changing the grub options – what can I do to truly hide them?

For the record, I hid them, did mk-grub2, rebooted, then we land here.

lspci doesn’t tell you if the devices are hidden or not, they will be in the list even if hidden.

You need to use lspci -vv and look for the property Kernel driver in use if it says pciback then rd.qubes.hide_pci is working, and the devices are hidden from dom0

1 Like

It does say on 0c, the device, “kernel driver in use: amdgpu” and on the other, “kernel driver in use: pciback”

So one is hidden, the other isn’t…?

i tried to hide it using commas instead of duplicating the cmd but with the small changes per device, remade grub, then rebooted… now lightdm won’t start. any ideas?

so, i got it switched. i DID have the right gpu the first time, and this gpu is the one that’s the primary. the one i tried to hide. sorry everyone - making a new post now to appropriately fit this issue