Pass through LAN IP to qube from Sys-net

My current setup is Main PC ↔ Network Switch ↔ NAS. My Main PC is currently running Qubes r4.2 – that said, my primary internet for my Main PC is a Built-into my mobo wifi – That said, when I try to ping my NAS, it doesn’t work. So I dug deeper – it works on sys-net, but not sys-firewall or anywhere else (besides dom0 ofc). My goal is to SSHFS it on a Qube with this arrangement netvm → firewall → VPN – and the endpoint being the vpn. Ifconfig also shows that my NAS’ IP,, isn’t detected. Any ideas?

I highly appreciate any help

It should work. Did you block anything in Qubes Firewall?

I did not. I didn’t do anything regarding the firewall what-so-ever – and I’ve also tried unplugging and replugging, rebooting Dom0, as well as various other “turn it off and back on” agains. That said, since sys-net sees it, I’m thinking I have to do something with sys-firewall dealing with iptables… but I’m not sure, as, I’m not good at networking yet.

Is internet working in sys-firewall at all? Can you ping your router from there?

Internet is completely functional from sys-firewall, besides for the switch – and from sys-firewall, I’ve pinged my external IP Address, which is what I’m guessing you mean… If not, I don’t know how to do so.

This issue also persisted on 4.1.2 back before I updated – I suspected that r4.2 would fix it, but it didn’t.

Wait, I may have gotten it – one moment.

I think what fixed it was me adding network-manager to sys-firewall then rebooting it. Ty for the help! I wouldn’t have done that without your thought process