Pairing a Logitech Mouse with a Unifying Receiver

Currently I’m using my backup mouse, because I couldn’t get my Logitech Marathon Mouse M705 working. I updated the Unifying Receiver on another machine to the latest firmware to fix the known security bugs.

But how can I pair the mouse with the receiver?
And in what qube should I do it?

I created the sys-usb qube according to the manual, because my Mainboard doesn’t have PS/2 ports.

So: How can I pair the Unifying Receiver with the Marathon M705?
What tool can I use (ltunify or Solaar) in which way and in what qube or template should I execute the commands?

The mouse is recognized in the “System Tools → Mouse and Touchpad” section of the Qubes System Tools, but the mouse still doesn’t work.

I’ve googled a lot, but didn’t find a satisfying answer.

I paired it on Windows and then it starts to work on Qubes. Maybe try to pair on Windows VM.

You could try another port/controller (if any other, the latter)

You could install Solaar for Debian. I can’t remember if I installed it in Qubes. I think I did at one time and it worked.

Thank you, this worked.

I assigned the USB Logitech Unifying Receiver to the “untrusted” qube. Then I installed Solaar, executed it, and first unpaired, then paired the device again and set the options.

Afterwards, I rebooted. After rebooting, Solaar was no longer installed and the mouse did not work at the login-screen(This was still the case after another reboot).

But after login it worked in all qubes as desired. Thank you.
(I did this in a Debian qube, but it should be similar in a Fedora one).

1 Like

I did this using ltunify in sys-usb. This worked for me.

1 Like

Hi, this doesn’t really apply to your issue but I would like to confirm one thing. You have your mouse connected to an AppVM and it is recognized/listed under system tools > mouse and touch pad?

See, I have another issue. My mouse is not recognized/listed but when I connect it to an AppVM it works except there is no cursor.

I just want to confirm to facilitate troubleshooting.


Even though you can, you’re not supposed to hook up the mouse to an AppVM other than sys-usb. If you do this, you will see no cursor corresponding to the mouse. The cursor is drawn in dom0, and since dom0 cannot know where the mouse is, it cannot update the cursor.