Option "Enable Wi-Fi" not showing in NetworkManager with sys-net based on a fresh installed and updated fedora-36-xfce template


I tried updating templates. Now “enable wi-fi” is not showing in the NetworkManager anymore when sys-net is based on fedora-36-xfce template. When switching back to fedora-34 (not xfce) it works again. I have not tried fedora-36 (not xfce) as I try to keep my system minimal and not have to many templates installed.
How can I get wi-fi working with this xfce setup?
I thought fedora-36 and fedora-36-xfce main difference is the windows manager, but there seems to be a missing component in xfce for wifi to work as it usually does.?


I see that you updated the above post. Some people, including some core developers, are interacting with this forum via email. They do not receive the edits made after 10 minutes. For this reason, it’s better to make a new post, not update the old one (and/or use quotations like I do here):

New version

Thanks fsflover, I tried to make my topic more clear by correcting it, albeit the question is basically the same. As such I was unsure if it was polite to make a new topic of it :wink:

Not a new topic but just a new post here (as I did above) would be fine I think.

It’s only works with Gnome-based template qubes to have wifi network as I founded out few weeks ago.

You could try creating a new sys-net from dom0, sudo qubesctl state.apply qvm.sys-firewall.

Was on vacation.
Now I downloaded & tried fedora-36 (gnome) for sys-net: Wi-Fi and the option “enable wi-fi” in the NetworkManager are working.
When switching to fedora-36-xfce template for sys-net, “enable wi-fi” is not showing in the NetworkManager and Wi-Fi is not working.
There must be difference in regard to the installed packages related to wi-fi between fedora-36 (gnome) and fedora-36-xfce.
Can someone point me to the missing wi-fi packages in the xfce template?

Try dnf install NetworkManager-wifi network-manager-applet

Thanks Joe… but both (NetworkManager-wifi & network-manager-applet) were already installed.

following Minimal templates | Qubes OS
I tried installing wireless-tools but this was not found.
Any suggestion what package xfce might be missing?

Don’t know what to tell ya other than HPOA909’s comment above but most of what I use came from that guide:

qubes-core-agent-networking qubes-core-agent-network-manager qubes-core-agent-passwordless-root gnome-keyring iwlax2xx-firmware notification-daemon NetworkManager-wifi network-manager-applet

The firmware is for Intel AX2xx wifi.

Why don’t you just list packages from both and diff them?

“Why don’t you just list packages from both and diff them?”
Sorry, I am to new to do this

only Package missing was the notification-daemon but installing that changed nothing.
wireless-tools & polkit@hardware-support were not found.

I give up this switch to xfce and will stay at the regular gnome fedora-36

Thanks for the help

Well, I’ll be darned. Today I rebooted and planed to remove fedora-36-xfce and I checked one last time and now WIFI worked!

One issue that still puzzles me: how do I know which software package to install for my wifi?
The AX2xx wifi did work BUT how & where would I have found this information by myself without your help?

I tried ‘lspci’ in dom0 and it showed intel wifi 8265 / 8275 (rev 78) which gives me no hint of ‘AX2xx’


There’s no reason to suppose that that firmware did anything, or that it
was right for your box. (It wouldn’t match the details you now provide,
and wouldn’t be loaded.)
8265/75 is covered in standard Fedora firmware-linux package.
It’s possible that this package was updated , or some kernel package was
updated during your install, and that fixed the issue.

journalctl -b will show you the log since the last boot and you can
search for firmware to see what has been loaded.

unman, you are right. It is working even after I removed AX2xx wifi.

while I remember back when I installed and rebooted package by package following Minimal templates | Qubes OS and joes instructions to see which one will make it work, it seemed to be the last one I installed, that being AX2xx wifi. but I guess I must have missed a reboot so it was already complete before that. Thanks for pointing out.

PS… after some automatic updates of fedora-36-xfce I ran into the same problem and could not solve it this time. I went back to using fedora-36 templates.