Open ports using a VPN

I have a VPN with port forwarding features. And I can use it just fine in kali-hvm. But I wanna use it in debian based appvm. I enabled network manager in services tab and did;
apt install network-manager-openvpn-gnome openvpn
My vpn config has two files. One is .ovpn and the other one is .crt. I imported the .ovpn and connected successfully. My IP has changed to my vpn provider, I have started the listener but I still get error when checking on And I am using sys-whonix as netvm.

What can I do to resolve this?

Anybody have some answers?

You have enabled VPN in sys-net, but you are using sys-whonix as netvm
for the qube to which you want to port forward?
I don’t use Whonix, but it seems unlikely that will work without some
serious hacking on the Whonix gateway, which you almost certainly don’t
want to do.
Have you read this?

You have enabled VPN in sys-net

Nope. I enabled VPN in my appVM named “work” which is standalone vm based on debian template. This “work” vm is where I want to say success. And for “work” vm, I have selected;
sys-whonix as networking.
sys-tor as networking vm which is based on fedora going through sys-whonix. This sys-tor, I use for windows, android and other HVMs too so that I don’t have to setup DNS setting for every HVM.

I read that, but didn’t understood much. I am gonna read it again.

What I actually wanna know, if I enabled network-manager in settings of appvm “work”, launched it, then connected to the vpn by importing the ovpn file, shouldn’t my ports should be opened? I mean that is why this vpn is for, to bypass router and firewall restrictions. So the user just have to forward the port on the vpn site and then connect to it from their computer.
So what am I doing wrong? And how do I fix it?

Anybody has any answers?