Only 12vcpus detected by qubes on a 12700k?

i have 20 vcpu’s on 12700k
qubes detects only 12

Anyway to solve this?


according to this site, your CPU has 12 physical cores, and 8 additional threads.

As SMT is disabled on qubes per default for security reasons, this is expected behavior.

1 Like

didn;t know that…
My threat model is not that high, is there a way to enable SMT??


If you really understand the risks that come with hyper threading and choose to accept them you can edit the command line of your xen hypervisor. I have not tried that, but it seems pretty straight forward.

On (my) 4.1 i would go into /boot/efi/EFI/qubes/grub.cfg, find all occurrences of “smt=off” and replace them with “smt=on”. 4.0 should work kind of the same, just look for some files in this directory with text and edit those.

1 Like

do i need to add this command also to the smt = on??
what does this command do??
in reference to this comment [qubes-users] Please submit R4.1 HCL reports! - #4 by awokd1

smt = on does enable smt.
sched-gran=core does set the scheduling granularity to one physical core as documented here. May not be nedded, i don’t know.

Be sure to read this first though:

and this