NVidia + Sys-USB = Disaster

I have been trying for the better part of a month to be able to use a Yubikey and other USB devices. I use an Nvidia GPU and USB kb + mouse. There seems to be some issue I have no idea how to troubleshoot:

  1. Sys-USB cannot be created at installation time, I lose display capability at end of install.
  2. After installation creating Sys-USB and starting it results again in display not functioning.

My GPU light on Nvidia goes from solid to flashing, it is either not in use or just crashed.

Please let me know how can we use sys-usb on systems with a gpu ?


Did you try to figure out if the issue is caused by some specific USB controller?

I see two controllers, I suppose motherboard has two controllers for its usb ports.
Usb 3.1 controller and USB 3.0 controller.

I have tried attaching each of them to sys-net individually and together. the result is the same. As soon as sys-net is started I lose my display entirely.

Strange thing is on a fresh qubes install I was able to attach usb device to sys-net and used the USB devices. After rebooting the same issue occurred again, monitor death on sys-net start.

I did the installation 5 times, as selecting the separate USB qube options caused a loss of display at end of installation. The only option that worked for this test install was everything on sys-net, no usb qube.

So, please if there is something I have not yet tried tell me so I may test it. Thanks.

You can check the logs in dom0 terminal with sudo journalctl and in these files:
There are multiple hypervisor.log files, find the one for the boot where you’ve tried to attach USB controller to qube.
Maybe there will be a clue of what’s happening there.

Okay this is very strange.
did fresh install with sys-net only for usb mouse/kb no sys-usb created.

  1. Connected USB devices before booting + attached the two visible USB controller devices to sys-net in its settings.
    ->black screens at user login prompt.

  2. Unplugged all USB except kb + mouse, kept sys-net setting to have two USB detected controllers/devices attached (both from motherboard)
    → Booted fine
    → Plugged in a USB devices all work fine
    → Plugged in a USB hub with several devices attached, they also all worked fine.

So it blackscreens only if USB devices OTHER THAN kb + mouse are plugged in at boot time.

I guess my questions now are:

  1. how to I get it to boot without blackscreen
  2. Is this way of connecting USB devices safe, are random usb connections being made to Dom0?
  3. If purchasing a PCI card USB controller/expander, would there be a more secure way to use USB devices on this qubes system?

Which USB devices are connected before booting? If you have just a single simple USB drive will it have black screen as well?

I just tested booting with the same USB devices plugged directly into PC instead of to USB splitter/hub.
→ No black screen, works fine.

So PC only loses display/crashes when the devices are connected to the USB hub.

What could be causing this and how can I fix it ?

Which USB hub is that? Can you tell its model?

Sabrent Model HB-UM43

If you only have this hub connected to your PC without any devices connected to it then will it cause the black screen?
If you have only a single USB device (specifically USB flash drive for a test, not some power-hungry device like external HDD) connected to this hub will it cause the black screen?