Not getting dom0 notices with the Gear Icon, but get templates

not getting dom0 notices with the Gear Icon, but get templates

is this common? how might I trouble shoot it please?

Hi, what do you mean by Dom0 not noticing with the gear icon ?

I mean there are updates available, but I am not getting cue’d by the Gear Icon when there are.

You just have to let some time pass for the system to detect them I guess ? By the gear icon you mean the yellow kind of sun up right ? How do you know update are available ?

I am not sure I understand your problem

I know there is a dom0 update, by running sudo qubes-dom0-update in dom0 , otherwise I have no way of knowing.

if you’ve been using Qubes, you’d know there is a gear icon that appears when there is updates as an icon on the far right of the taskbar in xfce

its NOT a matter of waiting for a long length of time 6 months+ I get no notification

Is your system configured to check for dom0 updates automatically?

Qube Manager -> System -> Global Settings -> Check for dom0 updates

Also, while you’re in there, make sure “Dom0 UpdateVM” is set to an appropriate VM (sys-firewall by default).

  1. yes global settings is set to check
  2. dom0 updatevm is sys-firewall

but doesn’t help ; having done 1& 2 above, this is qubes-prefs

$ qubes-prefs
check_updates_vm D True
clockvm - sys-netdisp
default_dispvm - whonix-ws-15-dvm
default_kernel - 4.19.147-1
default_netvm - sys-firewall
default_pool D lvm
default_pool_kernel - linux-kernel
default_pool_private D lvm
default_pool_root D lvm
default_pool_volatile D lvm
default_qrexec_timeout D 60
default_shutdown_timeout D 60
default_template - debian-10
management_dispvm - default-mgmt-dvm
stats_interval D 3
updatevm - sys-firewall

welp for whatever reason I just got a dom0 gear update notification … guess I don’t need to know why

On 4.0, dom0 updates are very infrequent relative to non-EOL TemplateVMs. Perhaps you’re expecting dom0 updates when there aren’t any.

or there is some kind of delay from when I can manually bring them up, and when the gear icon might show them ? think I’ve noticed that with some template updates

is this something (RTC) that might make it so dom0 doesn’t get updated/notices via the widget gear icon?

RTC in local TZ: yes

Warning: The system is configured to read the RTC time in the local time zone.
This mode can not be fully supported. It will create various problems
with time zone changes and daylight saving time adjustments. The RTC
time is never updated, it relies on external facilities to maintain it.
If at all possible, use RTC in UTC by calling
‘timedatectl set-local-rtc 0’.

I’ve just done as it requested hopefully it doesn’t break anything