Not enough space in /tmp in dom0

In Qubes OS R4.1 beta, I am trying to run six concurrent qvm-backup commands simultaneously like here. This has worked like a charm so far but now I am using a storage device that is luks-encrypted. Apparently, writing backups to an encrypted storage requires more free space in /tmp in dom0 and I get error messages like these:

./backup: line 59: cannot create temp file for here-document: No space left on device

It looks like the tmpfs mounted at /tmp is only 2 GiB and its usage is fluctuating quite a bit during the backup processes:

$df -h
Filesystem                   Size  Used Avail Use% Mounted on
tmpfs                        2.0G     0  2.0G   0% /dev/shm
tmpfs                        2.0G  207M  1.8G  11% /tmp
[...]

Does anyone know how to increase the tmpfs size? I assume that requires some hacky Xen commands…

I haven’t even used Qubes OS (yet) but perhaps this command (as root) will work:

mount -o remount,size=50% /tmp

The size option means percent of free memory. There is probably /tmp line in /etc/fstab file.

Thanks for the quick reply! There is nothing like that in the /etc/fstab and the remount does not work either. It is not difficult to find online how to resize the FS mounted at /tmp but it seems to be managed differently in Xen / Qubes.

These days under Linux, /tmp is typically RAM-based (i.e. the /dev/shm mount), and utilizes the RAM allocated to dom0.

I’m not sure what the next step is to not run into this issue. One could increase the dom0 RAM allotment, but that might simply put off the issue until a larger file/archive is encountered.

B

Well, RAM is precious under Qubes and I still say that despite having 64 GB of it… I hope there is some other way to get a larger capacity for /tmp.

It’s managed the same way.
You dont say in what way the remount does not work.
Try specifying an amount:

mount -o remount,size=4G /tmp

Works on 4.1