Non-Endpoint PCI device cannot be assigned to guests

Hi guys, i bought a Thinkpad x1 carbon 8 yesterday.

I can see it on the Hardware Compatability List (everything is fine on the report) but nothing can run. Usually the message is “Sys-net: Non-endpoint PCI devices cannot be assigned to guests”.

** I can open Firefox, File manager in qube Vault, but nothing work for other qube **

So i’ve tried everything on PCI troubleshooting but nothing change.

I also don’t see any internet connection and when I tried to add wifi connection in Network, everything is disabled.

not sure this will help

Hi @ppc
Thanks for reply. I tried it before. In Setting of VM I clicked on button ‘Configure strict reset for PCI devices’.
But nothing change.

1 Like

I found this qemu-kvm PCI passthrough error / Applications & Desktop Environments / Arch Linux Forums and this
And what about log
Can you post /var/log/libvirt/libxl/libxl-driver.log

Hi @Qwerty1111,
read the How to use PCI devices guide and also, provide us more information.

  1. Wifi ou Ethernet?
  2. Give the full output of qvm-pci ls in a dom0 terminal.
    Example of my host (not the same hardware than you):
[user@dom0 ~]$ qvm-pci ls
BACKEND:DEVID  DESCRIPTION                                                                                                                   USED BY
dom0:00_1f.6   Ethernet controller: Intel Corporation Ethernet Connection (10) I219-V                                                        sys-net (no-strict-reset=True)                                                           
  1. In the sys-net VM, in a terminal what is the output of the lspci, uname -a and ip a commands?

Hi @ludovic
Thanks for replied.

  1. Wifi

  2. full output of qvm-pci ls in a dom0 terminal:

  3. In the sys-net VM, in a terminal what is the output of the lspci , uname -a and ip a commands? No I can not open the Terminal in Sys-net VM because of the same error “Non-endpoint PCI device…guests”

@Qwerty1111 somehow you ended up assigning all your PCI devices to the ‘personal’ qube. That’s also why the other qubes (e.g. sys-net) can’t use the PCI devices.

  1. in the settings of ‘personal’ go to ‘Devices’ and move everything from ‘Selected’ to ‘Available’.
  2. in the settings for ‘sys-net’ also go to ‘Devices’ and make sure only ‘Network Controller: Intel Corporation’ and ‘Ethernet controller: Intel Corporation’ are assigned.

The HCL report also clearly states that the reporter had to upgrade the kernel to get Wifi to work.

1 Like

Thanks @Sven

In this case, I must use the Ethernet for upgrading the kernel?

If you remove the PCI bridge entries from the devices tab of sys-net settings, can you then start it?

@airelemental In that case it will say: Unable to reset PCI … no FLR,PM reset or bus reset available

And also enable strict reset for the device in the error message (from the bottom of the same devices tab).