No success at playing mp4's in VMs

Newbie to Qubes from years of Mint. New installation of QubesOS 4.0.3 and still in confusion mode. When in either the “Work” or a disposable VM and using Thunderbird, I cannot play mp4’s. Most other audio files play fine through firefox. But for mp4’s the video portion will play, but there is no audio. Error message pops up stating, that MPEG-4 AAC decoders not installed and I’m prompted to install them via the repos. Clicking to install the codecs seems to successfully add them to the already-present other two codecs, but still no audio on mp4’s afterward. Next attempt at playing any mp4 by opening them with “Videos (default)” results in the error message “Unable to Play File MP4 decoder is required to play the file, but is not installed”. Online searches have not resulted in a solution so far. How do I proceed from here please. Many thanks.

I have no idea about fedora templates, so I don’t know how to fix that specific issue. But my temporary suggestion would be to install vlc and use that.

Thanks but still no success. Unless I’m mistaken, I cannot install an app (such as vlc) directly through a VM, but need to do it through a template using Terminal. I tried “sudo dnf install vlc” but get the error message, “error: Unable to find a match vlc”. I don’t see any listings anywhere of installable programs (Like I am used to in Synaptic through linux mint), to find the full program name. Am I wrong in using vlc as an argument or am I missing something else. I did have a look through the “man dnf” pages and I’m still confused. Thanks

You are right, apps are usually installed in templates.
In Fedora you have to add the RPM Fusion Repository in order to be able to install VLC, if I recall it correctly. I think in Debian it is available without adding a repository.

There are a lot of good video players available:
https://www.tecmint.com/best-open-source-video-players-for-linux/

I’ve never had problems playing any modern video or audio file when I had one of these players installed but I don’t know, maybe there is a special mp4 that is missing a codec.

Thanks Raphael. I did manage to (apparently) install vlc following the vlc installation for fedora listed on their website. But I cannot access it as far as I can tell. I needed to enable the fusion repo with vim by toggling the 0 value to 1, before I could install vim, which then seemed to install. Is this normal by the way? Then in my VM I opened the Qube settings, then Applications and added vlc to the selected window. Closed out the vm in case that was needed, reopened and I still have no vlc access it seems.

Sorry that should have read install vlc.

For playing video content in general it’s easier to do with debian. So I suggest you change the template of that qube to debian-10, which you can easily do on that qube’s settings.

Then you can simply install vlc on the template with sudo apt install vlc (on the debian-10 template) and then starting up your VM.

Thanks deeplow. I have just gotten vlc to work in the fedora 30 disposable vm. It just needed a system reboot. But I will definitely try your debian suggestion though, as that’s far more familiar to me. Really enjoying the concept of Qubes. Will stick with it.

1 Like

Cool. For the sake of future notes (and if you still remember) can you mention the commands that worked for you to put it working on fedora? I remember having tried that a while ago with no sucess.

For future reference (an I had totally forgotten about this), there is unofficial (third-party) documentation on how to do this. But now that I read it, it seems overly complicated. Either way, I’ll leave it here:

Just rember that if you installed all that stuff on the DisposableVM and not on the TemplateVM, when you close it, you’ll loose all the changes :wink:

A post was split to a new topic: Playing media in Fedora-based qubes

@Qubesquark thanks a lot for your contribution :slight_smile: that’s pretty detailed!

In the future this will help many other users get VLC on fedora templates. If you don’t mind, I’ll move that explanation to the #user-support:how-tos section.

One of the nicest features of discourse is the search feature being pretty powerful so users are suggested with your answer if the message they’re drafting seems similar.

Sure; Hope it helps someone else. Feel free to edit it for clarity or corrections as needed. cheers

1 Like

Thanks again, @Qubesquark. The solution was moved here: