No sound running Qubes 4.0.3

I am running Qubes 4.0.3 on a Dell Inspiron 3668 Intel i3 7th gen core duo running 3.90 GHz with 16GB of DDR4 SDRAM. My cpu is VT-x (EPT) and VT-d capable and active. I have Qubes OS installed on an external 250GB Kingston SSD connected to USB3.0 and boot up on it from BIOS. My experience so far with Qubes 4.0.3 is fabulous. No issues with the exception of “no sound” through my headphones playing YT Videos (which play just fine with no sound) or when playing a video with audio using VLC Media Player. All is working well except “no sound.”

The pavaucontrol indicates my default Qube based on Fedora 30 detects my integrated sound device (green check marks on all), the headphones are showing (green check mark), and the sound meters are moving up and down indicating audio is streaming. However, there is no sound coming through the headphones. My sound adapter info is:

00:1f.3 Audio device: Intel Corporation 100 Series/C230 Series Chipset Family HD Audio Controller (rev 31)
Subsystem: Dell Device 0763
Flags: bus master, fast devsel, latency 32, IRQ 130
Memory at df220000 (64-bit, non-prefetchable) [size=16K]
Memory at df200000 (64-bit, non-prefetchable) [size=64K]
Capabilities: [50] Power Management version 3
Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel

Can someone please assist me? This issue is frustrating and I don’t want it to be a “show stopper” for me using Qubes. Thanks.

You are running pavaucontrol in dom0?
Have you checked under “Playback” that the respective qube is unmuted?
Have you checked under “Output Devices” that your output is unmuted?


I am looking at pavaucontrol under my Personal Qube. How would I view this under dom0? I will have to look at this again. Can you tell me specifically how to view pavaucontrol under dom0 rather than my personal Qube?

When logging in, I see the speaker icon on the latte dock at the bottom and when I hover over it, it tells me the volume is 86%. When I click on this icon, the volume control opens and I’m able to place a checkmark in the “Mute” box which does mute. But, when the checkmark is removed and status is returned to “Unmute,” there is still no sound. Under dom0 Volume Control > the Built-in Audio Analog Stereo section, the Port shows Headphones are “plugged in” and there is a green checkmark off to the right-hand side. This is unmuted and the volume level is moving up and down in sync with the volume level in whatever YT video is playing in the Web browser.

I have verified that the “Playback” and “Output Devices” output is unmuted.

  1. You choose “PulseAudio Volume Control” in he launcher under “System


  1. You open a dom0 Terminal and run ‘pavucontrol’


I edited my earlier input indicating further what I have done. Please see that. I did follow your directions and this is the same pulse audio control I referred to earlier where the volume level is moving up and down in sync with the level of audio playing in the YT video but no sound is evident through my pro headphones. These headphones are showing as “plugged in” and there’s a green checkmark showing it is detected and working.


it’s just that you say you see the indicator moving, which means data is being transferred. To avoid any misunderstandings, I am posting two screenshots from my system. Please note the mute button (the one that looks like a speaker). Is this how it looks on your system too?


No, not entirely. In your images, on the first screenshot for Output Devices, my “Headphones(plugged in)” is the same, the “Built-in Audio Analog Stereo” is the same, I have a level slider is present at or near 100% with (0.03dB), there is a rectangle with a “green” checkmark in it, and under the word “Silence” this slider moves right and left as the video is playing. What is different is that in the screenshot to the right of your speaker where you show …, mine shows a small box with an “x” in it. This tells me that the speaker is not active. So, it appears that something is not communicating. I certainly don’t have anything muted though. What I am doing is I’m running Qubes OS 4.0.3 over an SSD drive hanging off my USB 3.0 port. If it were installed internally in my computer, I’m not sure that would make a difference. What do you think? Might the issue be USB related rather than a non-detected sound card since it appears the sound card is being detected. I know when I run lspci in the terminal in Qubes OS, the sound adapter shows up as an Intel Corporation Sunrise Point-H HD Audio (rev 31), but when I run the same command in Arch or Ubuntu Linux, it shows up as an Intel Corporation Audio device (rev 31) but not Sunrise Point-H HD. Thank your for the assistance. I think you may have stumbled upon the issue here with the icon appearance of the speaker being a small box with an “x” in it rather than “…” following the speaker. Please let me know what you think I should do. Thank you.

To me the “X” would indicate that it’s muted. Have you clicked on it to see what happens?

Hi @datapioneer,
please also check in the Configuration tab that the good profile is selected (I think it should be something like Analog Stereo Output…)

If it doesn’t work do some tests with other profiles.

In my case that’s “Analog Stereo Duplex”


Of course. It is not muted. It’s the first thing I tried. Clicking on it does nothing. The speaker icon on the panel at the bottom of my screen is also not muted. I’ve set the Configuration from “Analog Stereo Output” to “Analog Stereo Duplex.” Nothing removes the “x” to the right of the small speaker icon when I return to “Output Devices” and look at the Port: Headphones (Plugged in).


I’ve tried other profiles under Configuration, such as “Analog Stereo Output” and “Analog Stereo Duplex.” None of the other profile options apply in my case.


I’ve attached a screenshot for output devices to show you exactly what I’m seeing. Note the small box with “x” inside. If I click in it, that box with “x” does not go away. I’ve checked all other options that would constitute a muted situation. All sound interfaces that apply have been unmuted.


This seems to be a good resource working through your issue. I don’t think it’s Qubes specific or has anything to do with you booting from an external device.

The first point on the list is something called Auto-Mute and it can be disabled using alsamixer (which is present in dom0). Maybe this or another point on this list can help you.

Personally I am out of ideas for now. Maybe someone else has another idea.

Good luck!

I launched alsamixer in the dom0 terminal and made certain that the AutoMut setting was “disabled.” I believe it already was. Then, I saved the setting using the command: sudo alsactl store. This returned no errors. After rebooting the system, nothing had changed. I navigated to /usr/share/pulseaudio/alsa-mixer/paths in dom0 and edited the analog-output-headphones.conf file where I searched for the [Element Speaker] stanza and commented out the “volume = zero” line and retained “switch = mute”, then navigated to the analog-output-speaker.conf file where I searched for the [Element Headphone] stanza and commented out the “switch = off” line and changed the “volume = zero” to “volume = merge.” Then rebooted the system. This had no effect. Finally, I visited the suggested site and searched for PulsaAudio/Troubleshooting - ParabolaWiki which suggested to return to the alsamixer and ensure that each column had “00” instead of “MM” under it, saved this interface configuration change with the command sudo alsactl store, hit Return, and no errors resulted. Then, rebooted the system once again. No change to audio resulted. I’m back to square one.

Any additional help would be greatly appreciated. Thank you, Sven for all your assistance.

My sound issue seems to be resolved now. I decided to perform a clean reinstallation of Qubes OS 4.0.3 from a new download .iso file today and after updating all the templates, dom0 template, and the Personal & Work templates created from Fedora 30 and Debian 10, respectively, I now have perfect stereo duplex sound while watching one of my YT Channel videos while in my Personal Qube.

I appreciate all the assistance.

Just a note. In a previous installation of Qubes (4.0.2? …1?), I also had a terrible problem with sound controls.

What I recall (from a few years back now) was a non-responsive audio gui, much like some of what’s discussed about. In fact, I seem to recall that nothing I touched on that gui had any bearing at all on the system’s audio.

I also reinstalled and that fixed the issue.

Just allow for the idea that there is something that flakes out in the audio apparatus, idiosyncratically.

Thank you, ToastedCoral. My sound issue is fine now. However, I am having issues with SimpleScreenRecorder and VokoScreen working on the AppVM created from Fedora 30 or Debian 10, respectively. The beat goes on.

Late to this…
But I was trouble shooting this for a while
Narrowed it down to newer kernel bug with pavu control
Simply didn’t update to latest for a while

Then I find a lazy Workaround method of simply powering down the screen after boot
Selecting pavu audio channel to unused device, setting back and sound working

Rinse/repeat every restart

2 posts were split to a new topic: No sound on HP Envy Laptop