No sound on HP Envy x360 Laptop

Hello Sven,

I’m also facing audio problems (seperate topic but no good tips yet) but I saw your screenshots and with my HP Envy laptop, even if I plugin the headphone next to my speakers I still see nothing in Dom0 with Pavucontrol with the tab Output Devices. No device at all. Can you think of some explanations for this and possible solutions?

Best regards,

Peter

Hi @pmb-nl,

if nothing at all shows up it might be either a driver or hardware issue. Let’s work through it systematically.

What is the output of ‘qvm-pci | grep Audio’ in dom0?

Have you ever had any other OS installed on this machine? … did sound work there?

Do you have a Windows HVM? … can you try assigning the PCI device for audio (see output of first question) to that HVM… does Windows detect and install drivers? … which? …does it work?

Hello Sven,

Below the answers to your suggestions.

qvm-pci|grep audio
dom0:00_lf.3 Multimedia audio controller: Intel Corporation Comet Lake PCH-LP cAVS

Before I had Windows on the machine where sound via the speaker of headphone was working properly. But I completely removed it to really focus on using Qubes OS.
I don’t have a Windows HVM.

On the personal VM in Firefox I start Youtube with music and I see the audio signal moving with the song but no sound at all and no output device visible on the Dom0 audio mixer in screen above on righthand side.

Best regards,
Peter

Well, looks like you are not alone: #6391

You might want to leave a comment in there and offer to help debug this. Sorry I got no better news for you.

You helped me, it got it working now.
The person on Github with issue #6391 mentioned a workaround solution with installing the sof-firmware. I check there and saw that the sof-firmware drivers were in mainstream Linux starting from 5.2 kernel.

So I only used the suggestion below in dom0, rebooted and it works. :wink:
“creating a file: /etc/modeprobe.d/dsp-fix.conf and putting options snd_intel_dspcfg dsp_driver=1 as the file contents”

Step by step I’m getting a happy Qubes experience.

Thanks Sven!

Best regards,

Peter