No Sound in Qubes, No Devices Listed

I am running Qubes 4.1. I have a Dell G7, standard Qubes installation. I doubt I can downgrade to 4.0 due to the processor being 10th gen, but could do that. I have no sound. No hardware is showing up in the list of outputs or inputs.

Under Audio Input in the Qubes, it says I have a microphone that I can attach. When I do attach it, I still don’t have an input listed.

My only inputs and outputs are all dummy inputs and outputs. I think I could possibly get sound in or out through HDMI.

Sound is enabled in the bios. I don’t think it’s something simple (like volume turned down).

Does anyone have any recommendations on what to do? I did see this machine had tested as working in the user list of working hardware.

If you do know what to do, if you could please explain with very simple instructions or suggestions, as I am very new to Qubes and Linux.

Hi @caressaam!

You may, or not, already have seen this small audio troubleshooting section in the documentation. Summary: in some cases, audio hardware isn’t visible because it is not supported by the kernel. Usually that happens with recent hardware, and installing a more recent version of the kernel sometimes helps. (The article explains how to do that.)

I believe that the fact you only see dummy inputs and outputs means that your hardware is not detected by dom0, and checking kernel versions is a first step. That being said, I might be wrong. If anyone knows better, please correct me!

The documentation also contains an article on audio virtualization. It explains how audio can be enabled in AppVMs, even though the audio hardware is managed by dom0. My understanding is that if your hardware is not detected by dom0, then audio virtualization is not the problem (yet), but I think it’s still useful to know those docs are there, as they explain in detail how the different pieces of audio management play together in Qubes OS.

Finally, for what is worth, I too would love to understand better how to troubleshoot when the only listed inputs and outputs are dummy inputs and outputs! :slightly_smiling_face:


How about using kernel latest, would that work? It’s rare case for audio to not work as far i know. Are you using sys-audio?

So I ended up just reinstalling Qubes, and then suddenly I could see my soundcard and had access to audio again. I was so happy.

Then I installed some programs, did some updates, and now the soundcard is completely gone again. I see the dummy sound card. Any ideas? I can’t keep reinstalling Qubes over and over (which takes several hours) just to get sound back if it’s then going to go away.


So I reinstalled EVERYTHING and then the sound was working again and I had inputs and outputs.

Then I updated dom0 and everything disappeared again. So the sound inputs and outputs disappearing relate to the dom0 upgrade.

How would I make sure I’m using the latest kernel?

If my sound card is no longer compatible with Qubes, I am willing to purchase and install an external sound card, provided I am sure it will work. Is this possible?

I figured out how to update the kernel. It is updating, although I may have tried this before and I’m not sure it helped.

Okay, I think the mystery may be solved?

In the .4 version of the kernal, I have access to sound, but not access to wifi.

In the .10 version (I think it’s .10?), I have access to WiFi but no access to sound.

In the .12 version (I think?), nothing runs, at all. It won’t even open.

I think it might make sense to stick with the .10 version and also install a USB audio port (with a chip in it for sound) that is compatible with Qubes. Do such things exist?

Does anyone know why .12 isn’t working and if the next upgrade will solve this or if I’ve done something wrong?

Okay so by default, sys-audio and sys-gui is handled by dom0.
I would suggest dom0 use kernel 5.4.x
then sys-net with kernel 5.10.x

It should work.

How is it possible to do this?

Right now I have been using the second boot option and selecting 5.4. Does that mean I’m already doing that or am I loading both with 5.4?

Is there a way to select for these options?

check uname -a in dom0 if it’s 5.4.x then you’re in the right path,
then go to Qube Manager > Right Click on sys-net and choose Settings > Go to Advanced Tab and select kernel 5.10.x

This is interesting. I got a new PC recently also with a 10th Gen Intel and when I initially installed 4.1 it came with 5.10 which had no working sound for me.

Since then I have tried both 5.11 & 5.12 and both have had fully working sound (and everything else).

Have a look at the list here, scroll down to “kernel-latest”

You can install any of those kernels specifically by number via:
sudo qubes-dom0-update kernel-latest-5.12.9-1.fc32.qubes.x86_64

You can check/confirm which kernel you currently have active with:
uname -r

For me, upgrading from 5.10 (and making sure you’re running something newer) was the only thing I needed to do to get my sound working perfectly fine. I’ve reinstalled Qubes a few times since then, sometimes with 5.11, sometimes with 5.12 and sound is always working, no updates have broken it again on me at any time.

Hopefully one of these solves your issues!

1 Like

I would prefer with current-testing repo.
it’s stable everywhere (and newer!)