No sound in Fedora 32 qubes

Hello there,

some time ago, I installed the Fedora 32 TemplateVM via sudo qubes-dom0-update qubes-template-fedora-32 as stated in the documentation.
Since then I used it mainly for NetVMs. Recently I tried to use it for different purposes (e.g. as a DVM for disposable qubes) and recognized that I am not able to play sound whatsoever in any Fedora-based qube.

When running pavucontrol in dom0 I only get a list of all running, Debian-based qubes on the tab Playback for which the sound works fine.

Can anyone think of a reason or even a solution for this? Did you have similar issues with Fedora-based qubes?

Thank you and have a great day!

could it be something related to this:

1 Like

Same here for me and what I understand - it’s a worldwide issue. This means, it shouldn’t work for anyone (with 4.0.3 or 4.0.4) and Fedora-32 templates/VMs at the time.
Am I correct?

There isn’t any solution at the time and I hope it will be fixed within the next coming updates…
For the time being, I’m doing all my “sound-stuff” with the Debian-10 template/VMs.


1 Like

Thank you for pointing me to that post. I don’t think that my issue is related, since it seems to be a problem for all qubes (from what I get, reading the post) - maybe even on kernel level - and on the other hand, sound on my Debian templates works fine.
Nevertheless, I don’t know for sure, but a clean reinstall (what fixed the problem in the other post) is not possible atm.

1 Like

Thank you for your reply!
Since it seems to be a general issue and not just bad configuration on my side, I’ll open a bug ticket.
I’ll keep you posted!

1 Like
1 Like

I’m not having sound problems with any of my qubes based on Fedora 32. Running QubesOS 4.0.3, 5.4.88-1 kernel.

1 Like

Working fine for me - 4.0.3, 5.4.91-1

1 Like

Ahh, was waiting for you (both) telling us that… :slight_smile:
Question now is: What exactly is wrong with the Fedora-32 templates of several Qubes users.

From what I found out:

  • it only happens to Qubes w/Fedora-32 template
  • you easily can find out, when none of those F32 qubes appear in the Audio mixer list
  • if I change the template to Debian-10, I immediately see the qube in the Audio mixer and sound is there

Any suggestions, which commands I should try, giving you more details and infos?

Cheers & Regards

1 Like

You could look at Audio Virtualization for ideas.

If you want any command run in a working Fedora 32 VM, let me know. I don’t know much about pulseaudio - I might have to go and read this :slight_smile:

1 Like

Following up on my own post…

Maybe try running the following command: pacmd list-sinks

I get the following in a working Fedora-32 based VM:

1 sink(s) available.
  * index: 0
	name: <vchan_output>
	driver: <module-vchan-sink.c>
	state: RUNNING
	suspend cause: (none)
	priority: 9000
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max request: 8 KiB
	max rewind: 0 KiB
	monitor source: 0
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	used by: 4
	linked by: 4
	fixed latency: 46.44 ms
	card: 0 <Qubes_vchan>
	module: 4
		device.string = "vchan_output"
		device.description = "Qubes VCHAN sink"
		device.class = "sound"
		device.icon_name = "audio-card"
		qubes-vchan-io-output: Qubes vchan Output (priority 0, latency offset 0 usec, available: yes)
	active port: <qubes-vchan-io-output>
1 Like

Is pulseaudio-qubes installed in your template? To find out, you can run rpm -qa | grep pulseaudio-qubes in any VM based on it.

If it is, you can try to reinstall the fedora template to see if the problem occurs for a fresh template. Then you can update it, and see if it breaks then.


Okay, (replying to the last post) with the rpm command I got nothing back, but a dnf install told me pulseaudio is already installed…

[user@fedora-32 ~]$ rpm -qa | grep pulseaudio-qubes
[user@fedora-32 ~]$ sudo dnf install pulseaudio
Fedora Modular 32 - x86_64                                                                                                                                       13 kB/s |  14 kB     00:01    
Fedora Modular 32 - x86_64 - Updates                                                                                                                            7.8 kB/s |  11 kB     00:01    
Fedora Modular 32 - x86_64 - Updates                                                                                                                             49 kB/s | 321 kB     00:06    
Fedora 32 - x86_64 - Test Updates                                                                                                                               9.7 kB/s |  13 kB     00:01    
Fedora 32 - x86_64 - Test Updates                                                                                                                               197 kB/s | 1.7 MB     00:08    
Fedora 32 - x86_64 - Updates                                                                                                                                     10 kB/s |  11 kB     00:01    
Fedora 32 - x86_64 - Updates                                                                                                                                    296 kB/s | 3.4 MB     00:11    
Qubes OS Repository for VM (updates)                                                                                                                            4.5 kB/s | 3.8 kB     00:00    
TeamViewer - x86_64                                                                                                                                             341  B/s | 867  B     00:02    
Package pulseaudio-14.0-1.fc32.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
[user@fedora-32 ~]$

and a ‘pacmd list-sinks’ brings up this:

[user@fedora-32 ~]$ pacmd list-sinks
No PulseAudio daemon running, or not running as session daemon.
1 Like

@Rooftop, @427F11FD0FAA4B080123 I get the exact same results as @TheGardner when running the commands.

@TheGardener Over at GitHub, donob4n gave me the solution:
Try to run sudo dnf install pulseaudio-qubes in your Fedora template(s). This seems to be some kind of interface necessary for pulseaudio to work within qubes.
I don’t get why it’s not already within our Fedora templates, but I’m glad it’s solved.
Do you know, when you installed your Fedora 32 templates by any chance?
Maybe there was a time when the pulseaudio-qubes package was missing in the repos…

1 Like

Working again. That was simple then…
Thanks much for your help, guys! :slight_smile:

1 Like

Glad it’s solved :slight_smile: can you mark post that solved the issue as the “solution”.

You do this by clicking the at the bottom of the post and then “Solution”. This way when people see your post, they can be taken right to the solution

1 Like

Guess the latter is for KnightWhoSaysNi cause I can’t do that with his post with my credentials


I think I installed the Fedora-32 template around Jan 20, 2021.

1 Like

@TheGardner I did - it just didn’t seem right to mark my own answer as solution ^^

@Rooftop That’s interesting - As I stated over at GitHub, I guess I installed around November 2020. Certainly possible that they fixed the package in the meantime and TheGardner and me just had bad timing :stuck_out_tongue_winking_eye:

1 Like

From reading other threads, what has happened to a lot of people was that they forcefully updated, which included the removal of a conflicting version of pulseaudio-qubes, when there was a conflict of package versions at some point. This occasionally happens with pulseaudio, when Qubes can’t keep up.

I’m not saying that this is what you did. There may be another issue that leads to this as well.

EDIT: Looking back at Sudo dnf update: requires pulseaudio, but none of the providers can be installed , did you perhaps do dnf update --best --allowerasing at some point? That could have been the problem.