No qubes i3wm package in 4.2

is this package no longer available?

I can see i3wm in the Qubes repository.
Can you elaborate on what you did?

Fedora 37 - x86_64                               11 kB/s |  22 kB     00:02    
Fedora 37 - x86_64 - Updates                     31 kB/s |  21 kB     00:00    
No match for argument: i3-settings-qubes

i3 on Qubes is nothing without the patches.

i3-settings-qubes is also in the repository. Do you use qubes-dom0-update in dom0 to install i3?

Yes, but there’s no such package. Do I need to enable a repository or something? I have default.

I see both in the “current” repository. They should be available to you without changing anything.
Can you go in Qubes Global Config and check in “Updates” what you are currently on for “Dom0 updates”?
Maybe you can try to temporarily select “all testing” and try both packages again, even if it should not be necessary.

Both packages are here:

1 Like

I gave up on this for a while, but this worked. There’s a different issue now, if I open a new tray icon the previous ones are messed up.

Again, this never happened in Qubes 4.1.

After opening a tray icon (sdwdate-gui)


Do you have any idea?

Not sure, I’ve never seen this happen on my Q4.2 system with i3.
Did you do a full system reboot after installing everything?
It looks like screen tearing to me. What is your GPU?

It’s an AMD GPU. It solves itself after reloading the config. However it’s annoying that something like new update available messes up the interface. :confused:

You could try the tear-free option in dom0 for the driver and see if that solves the problem:


Section "Device"
        Identifier      "AMD Graphics"
        Driver          "amdgpu"
        Option          "TearFree" "true"