No network connection via debian 12 templates after update to 4.2-rc4

I’ve been updating from 4.1 to 4.2-rc4 last few days. One issue I had was my sys-net and sys-firewall stopped working during the upgrade process (I’m not sure when). I eventually discovered changing the templates from debian-12 to fedora-38 fixed this. Both were newly installed templates.

Can’t find any other mentions of this. I can post on github issues, but wanted to check here first if no one else has this issue.

For now using fedora is fine with me.

Note: I had tried removing sys-firewall and recreating with:
sudo qubesctl state.apply qvm.sys-firewall

That created a new disposable VM based on debian, and still did not work. Switching the disposable template to Fedora did work.

out of curiosity, do you have iptables installed on that template? I remember having to fix something like that before

The debian12 was a new template, don’t think I altered it at all.

$which iptables

returns nothing

guess that’s your problem then. Firewalling is done using iptables. I remember seeing a bug that states that debian 12 templates are missing iptables.

ok, that makes sense

found this:

Seems like something they’re still trying to figure out even though this issue is closed? Seems bad if someone has debian set to their default that sys-firewall just doesn’t work as happened to me.

try installing iptables and you should be good again.

I’m fine using Fedora. At this point have many much bigger issues with my upgrade I need to attend to!

I’m reminded of this issue, but it appears to be about only dom0 updates, whereas yours seems to be about network connectivity in general:

That’s correct, nothing was updating. I actually seemed to have no network connectivity via sys-net or sys-firewall at all at first. Using sys-whonix was not a workaround (that was already my default). Had to set to change sys-net to fedora-38 first. Then I set sys-whonix to connect to sys-net directly. Before I eventually switched sys-firewall to fedora-38 as well.

( I could fairly easily test this to see if debian-12 is still not working at all for network if there’s anything you want me to check. But I’m also dealing with some bigger upgrade problems first.)